Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 86296 - huge memory leak in watch
Summary: huge memory leak in watch
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: procps
Version: 8.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-19 04:51 UTC by Adam Thompson
Modified: 2007-04-18 16:52 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-08-21 21:17:44 UTC


Attachments (Terms of Use)

Description Adam Thompson 2003-03-19 04:51:42 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET CLR 
1.0.3705)

Description of problem:
use of 'watch' utility to watch *any* program's output appears to cause it to 
use up memory at a rate of approximately 1 Mbyte/sec.

This naturally causes system instability when one leaves watch running in a 
terminal during a long (overnight) process...


Version-Release number of selected component (if applicable):
procps-2.0.7-25

How reproducible:
Always

Steps to Reproduce:
1. run 'watch' agains any program
2. watch RAM leak away...
3. use reset button to reboot system
    

Additional info:

Comment 1 Alexander Larsson 2003-03-19 08:23:53 UTC
I don't see this in 2.0.11-4. Can you test the version in RAWHIDE?


Comment 2 Adam Thompson 2003-08-21 21:17:44 UTC
cannot reproduce in RH9.0 or 2.1AS, and I no longer have any RH8.0 system



Note You need to log in before you can comment on or make changes to this bug.