Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 86290 - Upload new Help content for 2_4_0 release.
Summary: Upload new Help content for 2_4_0 release.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site
Version: RHN Devel
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chip Turner
QA Contact: Red Hat Satellite QA List
URL: https://rhn.redhat.com/help/
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-18 22:40 UTC by Clay Murphy
Modified: 2007-04-18 16:52 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-03-29 00:26:30 UTC


Attachments (Terms of Use)

Description Clay Murphy 2003-03-18 22:40:21 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
I'm opening this bug at Chip's request to ensure we upload the new RHN Help
content with the 2_4_0 release. I'm working up this text, as well as the 2_4_0
Release Notes, right now. I plan to have all changes committed to CVS by Noon
Thursday, 3/27 in expectation of the 3/31 production release.

Version-Release number of selected component (if applicable):
2_4_0

How reproducible:
Always

Steps to Reproduce:
1.Open Help.
2.Notice all new features are not documented.
3.Bitch at Clay.
    

Additional info:

Comment 1 Josef Komenda 2003-03-25 19:23:46 UTC
Will review edits in QA. 

Comment 2 Clay Murphy 2003-03-28 02:22:22 UTC
Chip,

The Help on smallville appears to be generated correctly. All pages are there.
Your script rocks!

Since you generated this help, however, I've completed incorporating changes to
the docs from the Release Notes. That said, the Help (Basic and Enterprise) will
need to be updated from CVS and regenerated. I've generated my own copies using
the latest files and everything looks good.

As for the Release Notes, the Internal version is posted on the RHN intranet
page with the PDF versions of the User Guide. I've removed all internal
references and Bug IDs from rhn-release-notes.xml since your checkout, so please
update first. To generate the External version using the makefile, from within
the release-notes directory issue the command RELEASE-NOTES-rhn . An HTML file
will be created with the name rhn-release-notes.html. (The internal HTML file
may also be created. If so, disregard.)

Please let me know if you need additional information. I can't wait to see all
of this in RHN!

Comment 3 Chip Turner 2003-03-28 04:01:38 UTC
whew, okay, this is all now in cvs and qa!

Comment 4 Josef Komenda 2003-03-28 20:44:18 UTC
404 error in the enterprise and Basic user guides: 

    3.5. Launching the RHN Website
https://rhn.webqa.redhat.com/help/basic/applet-launching-website.html

Comment 5 Clay Murphy 2003-03-28 21:32:40 UTC
As you mentioned, this is missing in Enterprise, as well as Basic. The page
appears correctly on smallville, where Chip staged the files:
http://smallville.devel.redhat.com/help/basic/applet-launching-website.html

It also appears in the HTML I test generated.

I've walked through the rest of Basic and Enterprise on webqa and this appears
to  be the only page missing. Something either went wrong in the generation or
the file transfer.

Comment 6 Clay Murphy 2003-03-28 21:36:14 UTC
I'm CC'ing Tammy on this bug as a request for her to upload the new versions of
the User Guide to redhat.com, specifically:
https://www.redhat.com/docs/manuals/RHNetwork/ref-guide/
and
http://www.redhat.com/docs/manuals/RHNetwork/ref-guide/enterprise/

Comment 7 Chip Turner 2003-03-28 23:36:46 UTC
fixed in cvs

Comment 8 Josef Komenda 2003-03-29 00:26:30 UTC
Looks good in QA, closing.


Note You need to log in before you can comment on or make changes to this bug.