Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 86280 - unable to launch arbitrary progs with args at login time
Summary: unable to launch arbitrary progs with args at login time
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdebase
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Petr Rockai
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-18 20:01 UTC by Landon Curt Noll
Modified: 2007-04-18 16:52 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-03-11 13:21:35 UTC


Attachments (Terms of Use)

Description Landon Curt Noll 2003-03-18 20:01:08 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
Under the most up2date KDE from RH8.0, one does not seem to have
the ability to launch programs with arguments at login time.

One can save a current KDE desktop environment but that is
not sufficient.   Consider the konsole.  KDE will preserve
the location of a konsole window, but one does not have
the ability to supply an -e command as well.

We need to launch a number of windows at login time where
the application needs additional arguments.  For example:

    konsole -e /usr/bin/ssh remote.host
    konsole -e /usr/bin/tail --retry --follow=name \
        --max-unchanged-stats=61 /some/log.file
    /usr/local/bin/some-x11-app args ...

Unless I have missed something somewhere, the current KDE
bluecurve setup does not give one the ability to launch
any program with args at login time.

Version-Release number of selected component (if applicable):
kdebase-3.0.3-14

How reproducible:
Always

Steps to Reproduce:
1.try to launch a konsole with the arguments:
    konsole -e /usr/bin/tail --retry --follow=name /tmp/foobar
2.
3.
    

Actual Results:  KDE does not give you the ability

Expected Results:  Something under Preferences will allow you to enter commands
for KDE to execute on login.

Additional info:

Had this ability been in place, then a work-a-round for
bug #86278 would have been possible.
One could have simply added /usr/bin/rhn-applet-gui to
the startup command list ...

Comment 1 Miloslav Trmac 2003-03-19 19:56:50 UTC
See ~/.kde/Autostart.

I'm not sure how to open this from the GUI though.

Comment 2 Landon Curt Noll 2003-03-20 19:19:41 UTC
Thanks Miloslav, for your clarification. 
 
The issue with this enhancement request IS the GUI. 
"Power users" can create files under ~/.kde/Autostart by hand, but 
not by means of the GUI. 
 

Comment 3 Miloslav Trmac 2003-03-20 19:43:09 UTC
Hey, I didn't say it is not in the GUI. I just honestly
don't remember where it is because I'm not using KDE
nowadays. I'm *sure* that there was a GUI way to open this
folder at some point in the past though.

Comment 4 Petr Rockai 2005-03-11 13:21:35 UTC
I suppose if you need to write shell scripts to be ran on login time, you can   
probably open the Autostart folder too. However, i leave this on upstream   
decision. Closing as UPSTREAM. (Note: for konsole, you can probably fix this 
by saving sessions that have ssh as their command and open those sessions and 
log out, you should get them back on login via session restoration). 


Note You need to log in before you can comment on or make changes to this bug.