Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 86274 - Little Endian dependancy
Summary: Little Endian dependancy
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: eCos
Classification: Retired
Component: Serial device driver
Version: 2.0 beta 1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Gary Thomas
QA Contact: Jonathan Larmour
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-18 17:52 UTC by Need Real Name
Modified: 2007-04-18 16:52 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-03-18 18:22:48 UTC


Attachments (Terms of Use)

Description Need Real Name 2003-03-18 17:52:14 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
'serial.c' calls the serial device driver's 'set_config' with 
key 'CYG_IO_SET_CONFIG_SERIAL_HW_RX_FLOW_THROTTLE', 'buf' points to 
a 'cyg_uint32' buffer. At least two serial device drivers, 'ser_16x5x.c' 
and 'sh_scif_serial.c', assume 'buf' points to a 'cyg_uint8'.  A big-endian 
target will fail.

I suspect most serial device drivers will have this problem because they all 
seem be derived from the same source.  This problem is not limited to the 2.0 
beta.  It also appears in the CVS sources.

I suggest better comments in 'serial.h' could have prevented this.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Examine the code.
2.
3.
    

Additional info:

Comment 1 Gary Thomas 2003-03-18 18:22:48 UTC
Affected drivers updated - nice catch, thanks.


Note You need to log in before you can comment on or make changes to this bug.