Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 86217 - Alt-Sysrq handling is inconsistent
Summary: Alt-Sysrq handling is inconsistent
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel
Version: 2.1
Hardware: ia64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Larry Woodman
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-17 14:06 UTC by Dave Anderson
Modified: 2007-11-30 22:06 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-04-04 17:17:49 UTC


Attachments (Terms of Use)

Description Dave Anderson 2003-03-17 14:06:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.9-e.3enterprise i686)

Description of problem:
Alt-Sysrq handling on ia64 in general is spotty at best.
Typically upon entering Alt-Sysrq with a supported key,
it displays only the help message, as if an incorrect key
were pressed; then it stays in that mode with any subsequent
key entry, repeating the help message.  Eventually it may/will
"get out" of the loop and perform the request.



Version-Release number of selected component (if applicable):
kernel-2.4.18-e.25

How reproducible:
Sometimes

Steps to Reproduce:
1. Enter Alt-Sysrq-T (or any other supported key)
2.
3.
    

Actual Results:  The help string is displayed and then repeatedly displays
with subsequent keystrokes:

Sysrq: HELP : loglevl0-8 reBoot tErm kIll saK showMem Off showPc unRaw Sync
showTasks Unmount
...

Expected Results:  The correct "Sysrq : xxxx" string for the key entered should
be displayed and the command initiated.

Additional info:

Comment 1 Bill Nottingham 2003-03-24 17:12:27 UTC
Out of curiousity - usb keyboard?

Comment 2 Dave Anderson 2003-03-24 17:50:21 UTC
yes, usb...

Comment 3 Bill Nottingham 2003-03-24 17:58:32 UTC
Does a USB keyboard on x86 show the same problem for you? I've seen something
similar with a USB keyboard on x86 and sysrq, so I wonder if it's a USB issue
and not an ia64 issue.

Comment 4 Dave Anderson 2003-03-24 18:25:51 UTC
Good question -- we just tried it on one x86 box here, and it worked OK.


Note You need to log in before you can comment on or make changes to this bug.