Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 86211 - Installer Crashes citing /usr/lib/anaconda/ as reason
Summary: Installer Crashes citing /usr/lib/anaconda/ as reason
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 8.0
Hardware: All
OS: Linux
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Mike McLean
Depends On:
TreeView+ depends on / blocked
Reported: 2003-03-17 10:38 UTC by Ranganath P. Kashyap.
Modified: 2007-04-18 16:52 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2003-05-21 09:50:44 UTC

Attachments (Terms of Use)

Description Ranganath P. Kashyap. 2003-03-17 10:38:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
traceback(most recent call last)

file "/usr/lib/anaconda/", line 786,in

file "/usr/lib/anaconda/iw/",line 149, in 

file "/usr/lib/anaconda/", line 632 , in 

file "/usr/lib/anaconda/", line 150, in 

file "/usr/lib/anaconda/", line 215, in 

file "/usr/lib/anaconda/", line 430, in 

file "/usr/lib/anaconda/",line 1110, in 

file "/usr/lib/anaconda/", line 54, in vgactivate 

file "/usr/lib/anaconda/", line 66, in 

OSError: [Errno 12] cannot allocate memory

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.try installing(on my machine though;-)

Actual Results:  installer crashes

Expected Results:  installer should proceed normally

Additional info:

Comment 1 Michael Fulbright 2003-03-17 19:24:25 UTC
How much RAM does your system have?

Comment 2 Ranganath P. Kashyap. 2003-03-18 05:30:54 UTC
System Info:-
P3 - 500MHz
Intel810 MotherBoard
64MB RAM (I was able to install Psyche on another s/m with 64MB RAM)
20GB HDD (with first partition for linux)

anything else?

Comment 3 Michael Fulbright 2003-03-21 15:58:44 UTC
I would recommend at least 128MB (192MB wouldn't hurt) of swap for this system.
How much were you using when the error occurred?

Comment 4 Ranganath P. Kashyap. 2003-03-27 10:31:28 UTC
i was using 128MB! the partitioning on the 20Gig disk was like 
first partition Ext2 3.5GB (Created using PartitionMagic)
second partition swap 128MB (Created using PartitionMagic)
third partition FAT32
fouth partition FAT32
fifth partition FAT32

Comment 5 Michael Fulbright 2003-04-02 20:23:17 UTC
Then probably you need to try 192MB of swap.

Comment 6 Ranganath P. Kashyap. 2003-04-04 05:01:29 UTC
do you think that is all the problem? how about the partitioning? am i doing it 

Comment 7 Michael Fulbright 2003-04-04 21:18:14 UTC
I would recommend creating a swap partition of at least 192MB.

Comment 8 Ranganath P. Kashyap. 2003-04-14 04:21:39 UTC
i tried using 256MB swap space; but that didn't help either!

Comment 9 Trev 2003-04-18 23:56:59 UTC
Hi, I just tried it on a system with 48MB RAM and got the same error, but when 
I did a text-only installation, it worked fine.

I don't think it has any relation to the swap, as it crashed *before* creating 
the swap partition! Must be a bug with 8.0 - the 7.3 install worked fine for me.

Comment 10 Michael Fulbright 2003-05-12 21:21:09 UTC
Usually 128MB is enough for the graphical install to start up and work. You need
the extra swap for upgrades usually since these take more RAM to process than a
fresh install.

Try booting with 'linux text' on the command line.

Comment 11 Ranganath P. Kashyap. 2003-05-21 09:50:44 UTC
it worked for me. thanks a lot

Note You need to log in before you can comment on or make changes to this bug.