Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 862 - Default PATH from /bin/login is not clever
Summary: Default PATH from /bin/login is not clever
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: util-linux
Version: 4.2
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-01-18 09:21 UTC by w.wouts
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-03-22 22:00:59 UTC


Attachments (Terms of Use)

Description w.wouts 1999-01-18 09:21:49 UTC
By default /bin/login will set a users $PATH to:
/usr/local/bin:/bin:/usr/bin This way the small/crippled
versions of programs will be used by default. So I suggest
that the default $PATH is changed to:
/usr/local/bin:/usr/bin:/bin The $PATH for root should be
changed from /sbin:/bin:/usr/sbin:/usr/bin to
/usr/sbin:/usr/bin:/sbin:/bin accordingly.

The best place to change this would be in /bin/login, though
I've just changed /etc/skel/.bash_profile for now. But the
latter may break login scripts if anything changes.

Comment 1 Mike A. Harris 2001-11-26 08:25:01 UTC
This bug was misassigned to dkl.  Since dkl is in QA, it is no wonder
the bug never got seen.  ;o)

This is not a bug.  The path is as it is expected to be.  Users desiring
an alternate default path, are free to reconfigure to their taste.


Note You need to log in before you can comment on or make changes to this bug.