Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 86196 - Copy and paste broken between perldoc and gnome-terminal
Summary: Copy and paste broken between perldoc and gnome-terminal
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: perl
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chip Turner
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-16 20:50 UTC by Need Real Name
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-03-25 16:02:49 UTC


Attachments (Terms of Use)
Perl script showing problem (deleted)
2003-03-16 20:51 UTC, Need Real Name
no flags Details

Description Need Real Name 2003-03-16 20:50:06 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
When pasting from a perldoc page, the resulting code is not usable by perl.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. type perldoc lwpcook
2. Scroll down to find an example with a method call, e.g. $ua =
LWP::UserAgent‐>new;
3. Paste the example into a document and run it using perl.

Actual Results:  Unrecognized character \xE2 at perldoc-test.pl line 3.



Additional info:

The hypen part of "‐>" is unusable. Perl expects "->"

Comment 1 Need Real Name 2003-03-16 20:51:18 UTC
Created attachment 90621 [details]
Perl script showing problem

Run using perl perldoc-test.pl

Comment 2 Need Real Name 2003-03-16 20:54:51 UTC
I am using gnome-terminal 2.0.1 if that helps.

Comment 3 Chip Turner 2003-04-16 14:04:14 UTC
this should be fixed in RH9

Comment 4 Need Real Name 2003-04-16 17:44:41 UTC
It's still broken in nine.
Updating version info.

Comment 5 Need Real Name 2003-05-04 09:49:53 UTC
"Copy and paste" is a basic function that should "just work".

I think the priority on this should be upped.

Comment 6 Need Real Name 2003-11-19 22:26:59 UTC
Is this fixed in Fedora Core 1?

Comment 7 Need Real Name 2004-03-16 12:22:44 UTC
Changing platform to RHEL 3.
Still broken.

Comment 8 Need Real Name 2004-04-01 17:48:39 UTC
Is there any progress on this?

Comment 9 Need Real Name 2004-04-14 22:33:22 UTC
Copy and paste is _badly_broken_ here - a document that contains
working code no longer contains working code once it has been
displayed and put through the clipboard.

Comment 10 Need Real Name 2004-07-12 21:49:24 UTC
This is still even broken in Fedora Core 2 (!), with one change: the
-> is working fine, but the character â is bad. It should have '.

If you look at CGI.pm, the perldoc is fine.

Comment 11 Need Real Name 2004-07-13 11:00:37 UTC
This is really a perldoc problem.

Comment 12 Need Real Name 2004-08-13 11:28:14 UTC
Changing to RHEL (where this is still broken) to see if that makes 
any difference.

Comment 13 Need Real Name 2004-10-19 14:37:16 UTC
One and a half years on, copy and paste still doesn't work :/

Comment 14 Ray Strode [halfline] 2004-11-05 02:37:37 UTC
Hi,
I'm going to reassign this to the owner of the perl package so this
can be looked at.

Comment 15 Need Real Name 2004-11-24 14:59:23 UTC
Want me to do this?

Comment 16 Marius Feraru 2004-11-26 16:13:32 UTC
use something like:
  LANG=C perldoc <whatever>

if you want to be able to "copy paste" code around.

Please remember that "perldoc" is a tool just like "man" â they are
used to _render_ documentation as nice as possible :)
So blaming them for rendering documents using neat âpublishingâ
quotes, emdashes and things like that seems quite inappropriate, even
thou I aggreee with all you: âcodeâ should be rendered verbatim.
(what is âcodeâ) ;-)


Comment 17 Miloslav Trmač 2004-11-26 17:40:05 UTC
There is the additional question of what "verbatim" means:
see e.g. (perldoc perlebcdic), search for "range explicitly".
The code sample below it contains ISO-8859-1 characters.
- If they were rendered verbatim, you would see nothing useful in
  non-ISO-8859-1 locales (like the default UTF-8).
- Man by default converts them to UTF-8, so you see the "correct"
  characters, but you can't cut-and-paste them if you are using
  a non-ISO-8859-1 locale.

That does not invalidate the original complaint about characters
like -'", though.

Comment 18 Need Real Name 2005-03-25 16:02:49 UTC
Cool - it works now. Thanks!


Note You need to log in before you can comment on or make changes to this bug.