Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 86184 - the variable is not sent
Summary: the variable is not sent
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: php
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-16 10:21 UTC by Abd Belahcene
Modified: 2007-04-18 16:52 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-04-07 13:25:23 UTC


Attachments (Terms of Use)

Description Abd Belahcene 2003-03-16 10:21:34 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
apache or php or both don't work properly on redhat 8.0.

the value val1 (in my script below : test1.php ) is sent to the script test2.php
which must print the value, but test2.php dosn't print anything

the same scripts run correctly on pvevious release RH 7.3 for example.
 


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.the variable sending by a php file to another one is not printed
2.
3.
    

Additional info:

    the two scripts used:
                             test1.php
<html>
<body>
<form action="test2.php" method="post">
                Send a value     <input type="text" name="val1" size=10><br>
                <center><input type="submit" value="Send"></center><br>
</form>
</body>
</html>
                         test2.php

html>
<body>
<?php
      echo "VALUE   IS ",$val1;
?>
</body>
</html>

Comment 1 Joe Orton 2003-04-07 13:25:23 UTC
This is because the "register_globals" setting is now turned off by default; 
please read the migration guide
file:///usr/share/doc/httpd-2.0.40/migration.html#id2846561
for more details.


Note You need to log in before you can comment on or make changes to this bug.