Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 86179 - Permissions not correct on SquirrelMail data dirs
Summary: Permissions not correct on SquirrelMail data dirs
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: squirrelmail
Version: phoebe
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Gary Benson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-16 02:15 UTC by William Hooper
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-03-19 16:26:13 UTC


Attachments (Terms of Use)

Description William Hooper 2003-03-16 02:15:23 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
Phoebe version 8.0.94

I used up2date to install SquirrelMail along with the httpd, php, and imap
components.  Tried http://myhost/webmail and got an error about the prefs file.

Version-Release number of selected component (if applicable):
squirrelmail-1.2.10-4

How reproducible:
Didn't try

Steps to Reproduce:
1. Install SquirrelMail
2. Try to login
    

Actual Results:  Error about opening prefs file:
 Error opening ../data/default_pref
 Default preference file not found or not readable!
 Please contact your system administrator and report this error.

Expected Results:  SquirrelMail logs me in and display INBOX

Additional info:

It seems the permissions on: /var/lib/squirrelmail/prefs and
/var/spool/squirrelmail/attach need to be set to apache.apache instead of root.root

Comment 1 Gary Benson 2003-03-18 10:53:01 UTC
I'm not able to reproduce this, and the permissions inside the rpm are correct.
 Please run 'rpm -V squirrelmail' and attach the results here.

Comment 2 William Hooper 2003-03-18 20:48:24 UTC
Here you go:
[whooper@poit whooper]$ rpm -V squirrelmail
S.5....T c /etc/squirrelmail/config.php
missing    /var/lib/squirrelmail/prefs/default_pref
[whooper@poit whooper]$ sudo ls -l /var/lib/squirrelmail/prefs/
total 12
-rw-r--r--    1 apache   apache         99 Feb 10 09:56 default_pref
-rw-r--r--    1 apache   apache          0 Mar 15 20:37 whooper.abook
-rw-------    1 apache   apache        998 Mar 17 18:59 whooper.pref
-rwxr-xr-x    1 apache   apache         14 Mar 15 20:42 whooper.sig
[whooper@poit whooper]$

The config.php I understand being changed, but the default_pref obviously 
exists.

I installed using the command "up2date squirrelmail" without httpd or php, so 
could this be an issue with the order that the deps were installed?  I see in 
the up2date log file:
"[Sat Mar 15 19:23:53 2003] up2date installing packages: ['squirrelmail-1.2.10-
4', 'httpd-2.0.40-20', 'php-4.2.2-16']".


Comment 3 Gary Benson 2003-03-19 09:51:03 UTC
That's strange.  Does it still say that /var/lib/squirrelmail/prefs/default_pref
is missing if you 'chown 0.0 /var/lib/squirrelmail/prefs/default_pref' (which is
as it comes from the rpm)?

There shouldn't be an issue with the ordering of the dependencies unless rpm
broke: the squirrelmail rpm requires that the httpd rpm is installed before it
so that the apache user and group are there, but that is all taken care of in
the specfile.

Comment 4 William Hooper 2003-03-19 16:17:51 UTC
Yep, that seems to fix it:

[root@poit prefs]# chown 0.0 default_pref
[root@poit prefs]# ll
total 12
-rw-r--r--    1 root     root           99 Feb 10 09:56 default_pref
-rw-r--r--    1 apache   apache          0 Mar 15 20:37 whooper.abook
-rw-------    1 apache   apache       1110 Mar 19 09:14 whooper.pref
-rwxr-xr-x    1 apache   apache         14 Mar 15 20:42 whooper.sig
[root@poit prefs]# rpm -V squirrelmail
S.5....T c /etc/squirrelmail/config.php
[root@poit squirrelmail]#

And changing the prefs directory back to root.root is caught by RPM:

[root@poit squirrelmail]# ll
total 4
drwx------    2 apache   apache       4096 Mar 19 11:08 prefs
[root@poit squirrelmail]# chown 0.0 prefs/
[root@poit squirrelmail]# rpm -V squirrelmail
S.5....T c /etc/squirrelmail/config.php
.....UG.   /var/lib/squirrelmail/prefs
[root@poit squirrelmail]# ll
total 4
drwx------    2 root     root         4096 Mar 19 11:08 prefs
[root@poit squirrelmail]# chown apache.apache prefs/
[root@poit squirrelmail]# rpm -V squirrelmail
S.5....T c /etc/squirrelmail/config.php
[root@poit squirrelmail]#

And of course having root.root on the directory breaks SM.

Well if having up2date install squirrelmail and deps on a fresh install can't 
reproduce it, then feel free to close this one.  Must have been some kind of 
fluke.

Comment 5 Gary Benson 2003-03-19 16:26:13 UTC
Yeah, looks to have been a fluke; thanks for all your help though.


Note You need to log in before you can comment on or make changes to this bug.