Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 86170 - gnome-terminal occasionally crashes on resize
Summary: gnome-terminal occasionally crashes on resize
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnome-terminal
Version: 8.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-15 16:55 UTC by Yaron Minsky
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-03-15 18:01:26 UTC


Attachments (Terms of Use)

Description Yaron Minsky 2003-03-15 16:55:36 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030313

Description of problem:
Occasionally, when gnome-terminal is resized, especially when it's busy doing
something, it will crash.  It's not enough to be cat-ing stuff to the screen,
and I don't know precisely what the cause is.  But pine can cause it to happen.

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. start up pine with a bunch of messages and go to the list view
2. Drag the corner of the screen around (i.e., resizing it.)  Pine will
repeatedly catch up, resizing the pine screen.  After a few minutes of this it
will probably crash.  It may literally take 5 minutes, although in practice this
happens to me annoyingly often.


Additional info:

Comment 1 Havoc Pennington 2003-03-15 18:01:26 UTC
Should be fixed in any newer version of vte.

(One way to make it less annoying if you don't want to upgrade is to run your 
terminals as "gnome-terminal --disable-factory" so they don't all crash at once.)

Comment 2 Yaron Minsky 2003-03-15 18:42:00 UTC
Which version of VTE is supposed to be fixed?  I got the up2date upgrade to
0.8.19-2, and the bug definitely persists in that version.

Comment 3 Havoc Pennington 2003-03-15 18:58:35 UTC
Any one in rawhide (.20 or higher probably). There isn't an errata for it, 
unfortunately.



Note You need to log in before you can comment on or make changes to this bug.