Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 86158 - ignoring keyboard and mouse inputs
Summary: ignoring keyboard and mouse inputs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: vnc
Version: 4.4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Adam Tkac
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-15 02:07 UTC by Aaron Straus
Modified: 2013-04-30 23:33 UTC (History)
1 user (show)

Fixed In Version: RHBA-2008-0685
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-24 19:35:50 UTC


Attachments (Terms of Use)
vnc log after server goes into yuck mode (deleted)
2003-03-18 14:37 UTC, Aaron Straus
no flags Details
Proposed patch (deleted)
2007-07-04 09:35 UTC, Adam Tkac
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2008:0685 normal SHIPPED_LIVE vnc bug fix update 2008-07-23 15:48:46 UTC

Description Aaron Straus 2003-03-15 02:07:30 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.1; Linux)

Description of problem:
the vnc server suddenly starts ignoring all mouse/keyboard inputs.  this has happened across multiple machines (all running RH8) and with many different vnc clients.  after reconnecting it continues to ignore inputs.  it happens when 1 or more clients are connected, but we haven't seen it without a client connected.   it also only seems to happen when a client is actually active i.e somebody is moving the mouse or typing.

we also run RH 7.3/7.1 and have not seen this bug.



Version-Release number of selected component (if applicable):
vnc-server-3.3.3r2-39.2

How reproducible:
Sometimes

Steps to Reproduce:
1.
2.
3.
    

Additional info:

Comment 1 Tim Waugh 2003-03-18 13:29:27 UTC
Please attach the log file that the server creates (in ~/.vnc).

Comment 2 Aaron Straus 2003-03-18 14:37:48 UTC
Created attachment 90640 [details]
vnc log after server goes into yuck mode

here is the log after the server goes into the no-input mode.

Comment 3 Aaron Straus 2003-09-03 14:46:37 UTC
We've noticed we can recover the session by killing the application in the 
foreground.   As soon as that application is dead, mouse/kbd input is accepted 
again. 
 
Also seen in RH9 on a completely up2date machine.  Killing the application in 
the foreground (evolution) seemed to bring everything back again.  

Comment 4 Aaron Straus 2005-03-02 18:36:33 UTC
Well here's an update.

We switched to KDE on our Redhat 8 box and never had it happen again (only in
GNOME).

However, recently we did have exactly the same symptoms occur on a RHEL3 WS U4
completely up2date box running KDE, so I guess this bug is still around :(?

Comment 5 Tim Waugh 2005-03-07 17:17:27 UTC
The recent 4.1 release of VNC has some changes to
xc/programs/Xserver/vnc/XserverDesktop.cc which look like they might be aimed at
this problem: specifically, the addition of a XserverDesktop::deferUpdate function.

Comment 6 Adam Tkac 2006-10-27 13:01:43 UTC
Please, test if this problem is in latest release of vnc

Comment 7 Aaron Straus 2006-10-27 13:51:21 UTC
Hi.  We've seen it with the latest release of VNC on RHEL 4 WS i386 (running KDE
in the VNC).  It happens pretty infrequently now (once every six months or so).  

Comment 8 Aaron Straus 2006-11-14 16:08:15 UTC
It happened twice in the last two weeks, so I'd like to re-open the bug.

Comment 9 Radek Vokal 2006-11-29 14:20:19 UTC
Comment #7 confuses me. Is this bug still for RHEL3 or RHEL4? 

Comment 10 Aaron Straus 2006-11-29 14:33:28 UTC
We upgraded to RHEL4 from RHEL3 and continue to see the bug.  We've seen it in
every release since good old RH8.

Comment 11 Adam Tkac 2007-03-28 18:07:06 UTC
(In reply to comment #7)
Moving to RHEL 4



Comment 12 Adam Tkac 2007-03-28 19:53:18 UTC
I've tried backport patch for this issue to rhel4. Could you please test
proposed update package and tell me your impressions?
http://people.redhat.com/atkac/test_srpms/vnc-4.0-12.el4.src.rpm

Regards, Adam

Comment 13 Aaron Straus 2007-03-29 00:07:58 UTC
I'll take a look, but unfortunately we mostly see this bug in production where I
can't easily update the VNC.  I'll give it a try on a non-production box though.
 Thanks!

Comment 17 Adam Tkac 2007-07-04 09:35:03 UTC
Created attachment 158509 [details]
Proposed patch

Comment 19 RHEL Product and Program Management 2007-11-29 04:27:26 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 23 errata-xmlrpc 2008-07-24 19:35:50 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0685.html


Note You need to log in before you can comment on or make changes to this bug.