Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 86140 - "possible process hang on thread death"
Summary: "possible process hang on thread death"
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc
Version: 7.3
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-14 19:53 UTC by Dave Johnson
Modified: 2016-11-24 15:08 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-06-24 17:00:44 UTC


Attachments (Terms of Use)

Description Dave Johnson 2003-03-14 19:53:42 UTC
Description of problem:
Threads in glibc have problems exiting appropriately.

Version-Release number of selected component (if applicable):


How reproducible:
Regularly

Steps to Reproduce:
1. run multithreaded app
2. if a thread receives a signal, it hangs
    
Actual results:


Expected results:


Additional info:

It looks like this has been out there for awhile, looked at the SRPMS and it 
doesn't look like fix is included (we see same stack trace as inktomi):

http://bugs.gnu.org/cgi-bin/gnatsweb.pl?debug=&database=glibc&cmd=view+audit-
trail&pr=3501

Comment 1 Ulrich Drepper 2003-04-22 06:10:33 UTC
LinuxThreads has problems with signals, this is nothing new.  Try RHL9 with NPTL
which should handle all these things nicely.

Comment 2 Brian Brock 2003-06-24 17:00:44 UTC
closing.


Note You need to log in before you can comment on or make changes to this bug.