Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 86138 - switching mouse ps2->usb->ps2 gives no mouse tracking
Summary: switching mouse ps2->usb->ps2 gives no mouse tracking
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-mouse
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-14 18:58 UTC by John Reiser
Modified: 2007-04-18 16:52 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-09-04 22:06:29 UTC


Attachments (Terms of Use)

Description John Reiser 2003-03-14 18:58:36 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020529

Description of problem:
Change mouse from ps2 to usb, then back to ps2 (shutdown and reboot for each
change.)  ps2 works the first time, usb works the second, but ps2 fails the
third time.

/etc/X11/XF86Config gets left with two lines
     Option "Device" "/dev/input/mice"
(one for Mouse0 and one for DevInputMice)
and this means that a ps2 mouse does not work.


Version-Release number of selected component (if applicable):
redhat-config-mouse-1.0.4-5

How reproducible:
Always

Steps to Reproduce:
1.Fresh install Phoebe-3 8.0.94 with ps2 mouse; finish firstboot.
2.Shutdown, remove ps2 mouse, plugin usb mouse, reboot.  Kudzu detects mouse
change.  Leave ps2 mouse configured (as-is: Do Nothing); also configure usb
mouse.  usb mouse works.
3.Shutdown, remove usb mouse, plugin ps2 mouse, reboot.  Kudzu detects mouse
change.  Leave everything as-is (choose Do Nothing).  ps2 mouse does not work
(cursor does not track mouse movement).
    

Actual Results:  X11 pointer does not track ps2 mouse after ps2->usb->ps2 history.

Expected Results:  X11 pointer tracks ps2 mouse after ps2->usb->ps2 history.

Additional info:

Changing Mouse0 to
    Option "Device" "/dev/psmouse"
enables ps2 mouse to work (and even usb mouse at the same time, because
DevInputMice still has /dev/input/mice).

(So because usb mouse is "always-enabled", then switching _to_ a usb mouse
should not edit XF86Config.)

Comment 1 Brent Fox 2003-04-03 21:49:20 UTC
This looks like a dupe of bug 84047.  What version of kudzu are you seeing this in?

Comment 2 John Reiser 2003-04-04 01:02:44 UTC
bugzilla won't let me view bug 84047, so I cannot comment on that.

It was stock phoebe-3 (RHL 8.0.94), so it was kudzu-0.99.96-1.

Having upgraded to RHL 9 with its kuzdu-0.99.99-1, things have gotten worse:
switching from working ps2 mouse to usb mouse (shutdown, unplug ps2, plugin usb,
boot, type a character within 30 seconds to get kudzu attention, notice ps2
mouse is gone, Do Nothing; kudzu said nothing about usb mouse) results in
failure to bring up the X11 server.  I see a newt/ncurses dialog box, and get to
the X11 log:
-----
(EE) xf86OpenSerial: Cannot open device /dev/psmouse
     No such device
(EE) Mouse0: cannot open input device
(EE) PreInit failed for input device "Mouse0"
     No core pointer
Fatal server error:
  failed to initialize core devices
-----
This does make sense (ps2 mouse is not there), but XFree86 4.3.0-2 should have
recovered by going on to DevInputMice on usb; phoebe-3's
XFree86-4.2.99.901-20030213 did recover this way.  Anyway, I say "No" to running
X configurator, get dropped into text console, login, shutdown, reboot, type a
character within 30 seconds to get kudzu attention, notice ps2 mouse is gone,
Remove ps2 from configuration.  kuzdu then automatically configures usb mouse [I
don't get a chance to say anything], graphical boot succeeds, usb mouse works. 
I notice that XF86Config has "/dev/input/mice" for both Mouse0 and DevInputMice.

Then switch back from usb to ps2 via: shutdown, unplug usb mouse, plugin ps2
mouse, reboot, type a character within 30 seconds to get kudzu attention, notice
new ps2 mouse, Configure.  Graphical boot succeeds, ps2 mouse works;
/dev/psmouse is in Mouse0 for XF86Config.  Plugging in a usb mouse (both ps2 and
usb mice now plugged in), both mice work.

So, things are still broken (switching "doesn't work automatically", and does
require manual intervention), but perhaps the breakage is more user friendly
(you don't have to know how to get to a text console from a X11 display that has
no mouse).  The goal: switching between ps2 and usb (or both), and saying "Do
Nothing" to kudzu, should just work (all plugged-in mice are operational) with
no further intervention.

Comment 3 Brent Fox 2003-09-04 22:06:29 UTC
I don't know what to do here.  Switching between PS/2, USB and even serial mice
works for me.  I am unable to reproduce this behavior with RHL 9 and the Severn
beta.  Resolving as worksforme.


Note You need to log in before you can comment on or make changes to this bug.