Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 86125 - setsysfont does not load console map
Summary: setsysfont does not load console map
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-14 15:40 UTC by Péter, Soós
Modified: 2014-03-17 02:35 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-03-14 16:06:00 UTC


Attachments (Terms of Use)

Description Péter, Soós 2003-03-14 15:40:45 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; hu-HU; rv:1.2) Gecko/20021206

Description of problem:
setsysfont (useing setfont) does not load the console map ($SYSFONTACM in
/etc/sysconfig/i18n).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.define a console map in /etc/sysconfig/i18n (SYSFONTACM)
2.run setsysfont utility
3.
    

Actual Results:  console map setting is discarded since there is no consolechars
utility

Expected Results:  console map is loaded

Additional info:
Here is my patch:

<-- cut here -->
--- setsysfont.old      2003-03-14 14:08:52.000000000 +0100
+++ setsysfont  2003-03-14 16:27:01.000000000 +0100
@@ -24,12 +24,15 @@
     consolechars -f $ARGS
   fi
 elif [ -x /bin/setfont ]; then
-  if [ -n "$SYSFONT" -a -n "$UNIMAP" ]; then
-    /bin/setfont $SYSFONT -u $UNIMAP
-  elif [ -n "$SYSFONT" ]; then
-    /bin/setfont $SYSFONT
-#  else
-#    /bin/setfont
+  if [ -n "$SYSFONT" ]; then
+    ARGS=$SYSFONT
+    if [ -n "$UNIMAP" ]; then
+       ARGS="$ARGS -u $UNIMAP"
+    fi
+    if [ -n "$SYSFONTACM" ]; then
+       ARGS="$ARGS -m $SYSFONTACM"
+    fi
+    /bin/setfont $ARGS
   fi
 else
   echo $"can't set font"
<-- cut here -->

Comment 1 Bill Nottingham 2003-03-14 16:06:00 UTC
This was fixed in the Phoebe beta.


Note You need to log in before you can comment on or make changes to this bug.