Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 86123 - MyODBC is not correctly build
Summary: MyODBC is not correctly build
Keywords:
Status: CLOSED DUPLICATE of bug 77635
Alias: None
Product: Red Hat Database
Classification: Red Hat
Component: ODBC
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tom Lane
QA Contact: Permaine Cheung
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-14 15:26 UTC by Cecil Westerhoff
Modified: 2013-07-03 02:59 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:52:12 UTC


Attachments (Terms of Use)

Description Cecil Westerhoff 2003-03-14 15:26:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
When made a connection with isql every command except quit gives:
 isql: relocation error: /usr/lib/libmyodbc.so: undefined symbol:
>> _init_dynamic_array

After rebuilding the problem is solved.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. isql <database>
2. give any command except quit (including non-existing commands)
    

Actual Results:  isql: relocation error: /usr/lib/libmyodbc.so: undefined symbol:
>> _init_dynamic_array

Expected Results:  Getting output from my SQL command

Additional info:

rpmbuild --rebuild followed by rpm -Uvh solves the problem

By the way, I work with RedHat 8.0, but I coould only choose 7.1.

Comment 1 Tom Lane 2004-03-09 01:30:02 UTC
This has been fixed in an 8.0 errata; see bug #77635.

*** This bug has been marked as a duplicate of 77635 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:52:12 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.