Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 86121 - grub cannot boot windows 98
Summary: grub cannot boot windows 98
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: grub
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-14 15:01 UTC by marcos
Modified: 2007-04-18 16:52 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-08-06 22:06:07 UTC


Attachments (Terms of Use)
grub config file (deleted)
2003-03-14 22:17 UTC, marcos
no flags Details
device map file (deleted)
2003-03-14 22:19 UTC, marcos
no flags Details

Description marcos 2003-03-14 15:01:03 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)

Description of problem:
I have windows 98 on a 10GB HDD. bought an 80GB HDD partitioned it for linux 
20GB for / partition 256MB for swap and 200MB for /boot.

the 80GB is now the master drive and linux boots fine using GRUB...But When i 
try to boot Win98 with GRUB the screen goes blank and shows:

rootnoverify (hd1,0)
chainloader +1

it stops there...i tried modifying the boot commands to:

map (hd0) (hd1)
map (hd1) (hd0)
rootnoverify (hd1,0)
chainloader +1

the windows splash screen shows up, and you can hear HDD activity. but the 
screen goes blank and it stops doing anything why?

i can get windows to boot by going into the bios and changing the boot order to 
boot from my 10GB HDD. but i would like to avoid doing that everytime i want to 
change the OS i'm working in

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.boot computer
2.try to boot windows 98 using GRUB

    

Actual Results:  screen goes blank then shows:
rootnoverify (hd1,0)
chainloader +1

Expected Results:  windows 98 should boot

Additional info:

AMD duron 800,128 MB SDRAM,80GB HDD master,10GB HDD slave, voodoo 3 2000 PCI

Comment 1 Jeremy Katz 2003-03-14 15:27:04 UTC
Could you attach /boot/grub/grub.conf and /boot/grub/device.map?

Comment 2 marcos 2003-03-14 22:17:58 UTC
Created attachment 90606 [details]
grub config file

this is what the file had in it had to type it in windows notepad to send

Comment 3 marcos 2003-03-14 22:19:01 UTC
Created attachment 90607 [details]
device map file

same as above

Comment 4 Jeremy Katz 2003-08-06 22:06:07 UTC
Unable to reproduce.  This looks like it's almost certainly Windows not liking
having its drive moved around.


Note You need to log in before you can comment on or make changes to this bug.