Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 86118 - libxml and libxml2 src rpms have same spec filename
Summary: libxml and libxml2 src rpms have same spec filename
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: libxml2
Version: 1.0
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Veillard
QA Contact:
URL:
Whiteboard:
: 88813 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-14 10:43 UTC by Denice
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-03-25 13:48:35 UTC


Attachments (Terms of Use)

Description Denice 2003-03-14 10:43:40 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
This is picky of me, but in all of rawhide, there are only three 'dual-versioned
packages' that use the same SPEC filename for both versions of the source rpm:

 readline/readline41    --> readline.spec
 libxml/libxml2         --> libxml.spec
 slang/compat-slang     --> slang.spec

It would be nice if the name of the spec files were different in these packages,
so that you would not nuke the 1st spec file on installing the 2nd src.rpm file..


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. rpm -i libxml*src.rpm
2. look at files in SPECS
3.
    

Additional info:

Comment 1 Denice 2003-03-14 10:48:24 UTC
oops, I meant to set the perceived priority to low :o}

Comment 2 Daniel Veillard 2003-03-14 11:20:50 UTC
Well, I understand the problem, it's doable especially since the
libxml.spec is actually generated by configure. I could then rename
it to libxml2.spec without loosing the CVS history of the spec file
in the GNOME CVS.

Daniel

Comment 3 Daniel Veillard 2003-03-21 21:24:38 UTC
Okay fixed upstream in GNOME CVS base. This will propagate to any
libxml2 release post 2.5.4, i.e. in 2.5.5 when available.

Daniel

Comment 4 Daniel Veillard 2003-03-25 13:48:35 UTC
Okay libxml-2.5.5 has been released and is being pushed to RawHide.
It uses libxml2.spec instead of libxml.spec .
You can get it from ftp://xmlsoft.org/

Daniel

Comment 5 Daniel Veillard 2003-04-14 15:47:49 UTC
*** Bug 88813 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.