Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 86117 - troff malform the text stream when used by man
Summary: troff malform the text stream when used by man
Keywords:
Status: CLOSED DUPLICATE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: groff
Version: 8.0
Hardware: All
OS: Linux
high
medium
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-14 10:42 UTC by Andy Shevchenko
Modified: 2007-03-27 04:01 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:52:12 UTC


Attachments (Terms of Use)

Description Andy Shevchenko 2003-03-14 10:42:12 UTC
Description of problem:
2 problems of man was observed.

First, man can not output correct text in 8bit locale such as ru_RU.KOI8-R.
If use troff with -Tnippon (in this locale) the input stream is broken, but
all formatting is correct (all russian symbols are changed by sequence '& ').

Second, in the ru_RU.UTF-8 locale man pages have incorect width and white space
position.

For example, type in ru_RU.UTF-8 following command:
man zic

in 80x24 terminal window you can see only half fill of it.
like  this:

(russian word DESCRIPTION)
Zic  word1 word2 word3 ...  _CLEAN SPACE_
     wordn, ...             _CLEAN SPACE_

where _CLEAN SPACE_ is equal to approx. 30symbols

Another bug is incorrect calculation of white spaces.
Take above example and see this man page like this

Zic  word1 word2 word3 word4_first_part
     word_4_last_part word5 ...  
     wordn ...

where word4_first_part + word4_last_part equal to whole word.
For example, 'word' is broke as 'wo' + 'rd' on different lines.


Version-Release number of selected component (if applicable):
man-1.5k-6 from rawhide
groff-1.18.1-20 from rawhide

Comment 1 Thomas Woerner 2004-04-22 12:23:02 UTC

*** This bug has been marked as a duplicate of 78915 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:52:12 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.