Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 86109 - Ctrl+Alt+Backspace to kill X server doesn't work
Summary: Ctrl+Alt+Backspace to kill X server doesn't work
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-14 07:58 UTC by H. Peter Anvin
Modified: 2007-04-18 16:52 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-04-06 06:58:29 UTC


Attachments (Terms of Use)
Xmodmap file used (deleted)
2003-03-14 07:59 UTC, H. Peter Anvin
no flags Details

Description H. Peter Anvin 2003-03-14 07:58:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030211

Description of problem:
Pressing Ctrl+Alt+Backspace doesn't kill the X server.  This has been observed
on three different system running Phoebe-3.

What is really odd is that Ctrl+Alt+Fx to switch VT works on exactly one of
these three systems, on the other two it is broken as well.


Version-Release number of selected component (if applicable):
Free86-4.2.99.3-20030115.0

How reproducible:
Always

Steps to Reproduce:
1. Log in using the graphical login in a KDE session
2. Press Ctrl+Alt+Backspace to zap the X server
3.
    

Actual Results:  Nothing

Expected Results:  The X server should have died and the login screen reappeared

Additional info:

Comment 1 H. Peter Anvin 2003-03-14 07:59:29 UTC
Created attachment 90597 [details]
Xmodmap file used

Comment 2 Mike A. Harris 2003-03-14 23:45:09 UTC
There were some 'issues' with xkb all along the latter months of XFree86
4.2.99.x, but all known issues were fixed prior to the final release.

Please test 4.3.0-2.1 from ftp://people.redhat.com/mharris/testing/unstable
and update me if it fixes it for ya.

Comment 3 Mike A. Harris 2003-04-06 06:58:29 UTC
I can kill the X server using CTRL-ALT-BS in a fresh Red Hat Linux install
on an Intel Northwood system with an i865 chipset.  I believe the problem
was fixed between Phoebe beta 3 and the final release.

If the problem still occurs for you with RHL 9, please reopen.

Thanks.

Comment 4 H. Peter Anvin 2003-04-06 09:04:38 UTC
I have identified that the problem is with the Xmodmap file -- unlike previous
versions of XFree86, the current XFree86 seems to require explicit Xmodmap
entries for the zap functions.  It claims they are synthesized if not present,
but that doesn't actually seem to be the case.

Adding the relevant XF86_* entries to the Xmodmap file resolved the issue.


Comment 5 Mike A. Harris 2003-04-06 11:27:26 UTC
Ok, thanks for the update hpa.


Note You need to log in before you can comment on or make changes to this bug.