Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 86093 - evolution not remembering that POP messages are received
Summary: evolution not remembering that POP messages are received
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: evolution
Version: 9
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-13 21:09 UTC by Guy Streeter
Modified: 2016-02-10 01:32 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-06-29 20:48:20 UTC


Attachments (Terms of Use)

Description Guy Streeter 2003-03-13 21:09:45 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
I have POP accounts set to leave messages on the server. Every time I receive
mail from the POP account, all the messages on the server are fetched again, and
appear multiple times in my local Inbox folder.

Version-Release number of selected component (if applicable):
evolution-1.2.2-4

How reproducible:
Always

Steps to Reproduce:
1. set up a POP account with 'leave messages on server'
2. hit the send/receive button several times.
3.
    

Actual Results:  multiple copies of each msg.

Expected Results:  each msg retrieved only once.

Additional info:

This setup worked as expected using version 1.0.8.

Comment 1 Jeremy Katz 2003-04-02 05:31:04 UTC
I don't see this here...  what's the server on the remote side?  You might also
try running `CAMEL_VERBOSE_DEBUG=1 evolution-mail` in a terminal and then
starting in evolution from another terminal (once evolution-mail says its up and
running) and look at the pop traffic for anything obvious

Comment 2 Guy Streeter 2003-04-02 16:49:37 UTC
The server is
Cubic Circle's v1.31 1998/05/13 POP3

Comment 4 Ivo Sarak 2003-04-02 23:03:00 UTC
It is exactly the same problem as 
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=78456

So there is nothing someone can do about it except not to leave the messages on
POP server or is there a way?

Comment 5 Guy Streeter 2003-04-02 23:10:30 UTC
I think this is not the same as 78456. I reported that evolution shows all the
messages on the pop server as new messages, and downloads them all as new
messages every time you click send/receive, so you see multiple copies of every
one in your evolution inbox.

Comment 6 Adam Pribyl 2003-04-28 12:36:41 UTC
This bug was very common in some old versions of evolution (how I found in
evolution bugzilla). It seems it is back again (I have the same behaviour). In
evolution bugzilla they are allways suggesting that you need to create directory
~/evolution/config because it is not created as it should. But I had this dir
with lot of file and it happen also.
What I did now, I removed all evolutions settings a reinicialized it (I upgrade
evo from 1.0.8 so I lose a lot of settings :( ). Then I created
~/evolution/config dir and for now it seems it is OK.


Comment 7 Adam Pribyl 2003-05-14 10:59:32 UTC
The problem is back again. I am susspicions about that it somehow relates to the
fact that mailbox is also accessed with pine.

This is not same as #78456 but it can be dependent. I also noticed that
evolution is too long reading POP summary. The long POP summary read is mainly
noticable when using SSL.



Comment 8 Jeremy Katz 2003-06-29 20:48:20 UTC
This is due to the pop server not implementing the UIDL extension.  1.4 works
around this.


Note You need to log in before you can comment on or make changes to this bug.