Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 86082 - TB cipeconfig.py:191:updateRemoteOptions
Summary: TB cipeconfig.py:191:updateRemoteOptions
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network
Version: 8.0
Hardware: i586
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
: 86083 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-13 17:50 UTC by Kim Lux
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-08-11 14:10:23 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2003:183 normal SHIPPED_LIVE Updated redhat-config-network package available 2003-08-11 04:00:00 UTC

Description Kim Lux 2003-03-13 17:50:18 UTC
From Bugzilla Helper:User-Agent: Mozilla/5.0 (compatible; Konqueror/3; Linux)Description of problem:I'm setting up cipe with neat.When I select the device to tunnel through, neat crashes.This happens on 2 computers.Version-Release number of selected component (if applicable):The one shipped with psycheHow reproducible:AlwaysSteps to Reproduce:1. Start neat.  Supply password as necessary2. Select cipe device cipcb03. Press Edit4. Select Tunnel Settins5. in the "Tunnel through device" field, select eth0 Actual Results:  neat crashes.  It shouldn't.Here is the text of the crash:Traceback (most recent call last):  File "/usr/sbin/../share/redhat-config-network/netconfpkg/gui/cipeconfig.py", line 191, in updateRemoteOptions    d = fields[0]IndexError: list index out of rangeBTW: I get the following on the terminal when I run neat:$ neat** (neat:10747): WARNING **: could not find handler `on_remotePeerAddressCB_toggled'** (neat:10747): WARNING **: could not find handler `on_ethernetDeviceEntry_changed'** (neat:10747): WARNING **: could not find handler `on_cipeDeviceEntry_changed'** (neat:10747): WARNING **: could not find handler `on_remoteVirtualAddressEntry_changed'** (neat:10747): WARNING **: could not find handler `on_secretKeyEntry_changed'** (neat:10747): WARNING **: could not find handler `on_generateKeyButton_clicked'** (neat:10747): WARNING **: could not find handler `on_localPortEntry_changed'** (neat:10747): WARNING **: could not find handler `on_remotePeerAddressEntry_changed'** (neat:10747): WARNING **: could not find handler `on_remotePeerAddressEntry_changed'** (neat:10747): WARNING **: could not find handler `on_localVirtualAddressEntry_changed'** (neat:10747): WARNING **: could not find handler `on_cancelButton_clicked'** (neat:10747): WARNING **: could not find handler `on_deviceNameEntry_insert_text'** (neat:10747): WARNING **: could not find handler `on_okButton_clicked'** (neat:10747): WARNING **: could not find handler `on_deviceNameEntry_changed'** (neat:10747): WARNING **: could not find handler `on_hardwareAliasesToggle_toggled'** (neat:10747): WARNING **: could not find handler `on_ipStaticRadio_toggled'** (neat:10747): WARNING **: could not find handler `on_ipAutomaticRadio_toggled'** (neat:10747): WARNING **: could not find handler `on_hardwareProbeButton_clicked'** (neat:10747): WARNING **: could not find handler `on_hardwareMACToggle_toggled'Expected Results:  It should have accepted the new "tunnel through" device.Additional info:None that I can think of.

Comment 1 Harald Hoyer 2003-03-14 11:18:27 UTC
*** Bug 86083 has been marked as a duplicate of this bug. ***

Comment 3 Harald Hoyer 2003-08-11 14:10:23 UTC
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2003-183.html



Note You need to log in before you can comment on or make changes to this bug.