Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 86060 - maindialog.py:198:__init__:NameError:global name 'timeout_add' is not defined
Summary: maindialog.py:198:__init__:NameError:global name 'timeout_add' is not defined
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
: 86228 87744 88745 103633 103688 105778 108412 110949 112010 114395 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-13 12:14 UTC by Jeff Novick
Modified: 2007-04-18 16:51 UTC (History)
10 users (show)

Fixed In Version: 1.2.15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-08-11 14:33:03 UTC


Attachments (Terms of Use)

Description Jeff Novick 2003-03-13 12:14:59 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030206

Description of problem:
redhat-config-network crashes with an unhandled exception as soon as I start it.

This is a fresh install, not an upgrade nor a dual boot system.

It occurs every time it is run, either by clicking the icon or running it on the
command line.



Version-Release number of selected component (if applicable):
redhat-config-network-1.1.97-1

How reproducible:
Always

Steps to Reproduce:
1. run redhat-config-network either by CLI or GUI
2.
3.
    

Actual Results:  Unhandled exeception, then traceback results, then nothing.

Expected Results:  I believe I should have received an interface similar to
RH8.0's network configuration tool.

Additional info:

Component: redhat-config-network
Version: 1.1.97
Summary: TB
/usr/src/build/222302-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py:198:__init__:NameError:
global name 'timeout_add' is not defined
Traceback (most recent call last):
  File "/usr/sbin/redhat-config-network-gui", line 154, in ?
    window = mainDialog()
  File
"/usr/src/build/222302-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 198, in __init__
NameError: global name 'timeout_add' is not defined
 
Local variables in innermost frame:
widget: <gtk.VBox object (GtkVBox) at 0x8664674>
notebook: <gtk.Notebook object (GtkNotebook) at 0x865ad3c>
page: 0
glade_file: /usr/share/redhat-config-network/netconfpkg/gui/maindialog.glade
self: <netconfpkg.gui.maindialog.mainDialog instance at 0x85fed34>
----------------
Component: redhat-config-network
Version: 1.1.97
Summary: TB
/usr/lib/python2.2/site-packages/rhpl/exception.py:280:handleException:TypeError:
generic_error_dialog() got an unexpected keyword argument 'dialog_type'
Traceback (most recent call last):
  File "/usr/sbin/redhat-config-network-gui", line 169, in ?
    handleException(sys.exc_info(), PROGNAME, PRG_VERSION)
  File "/usr/lib/python2.2/site-packages/rhpl/exception.py", line 280, in
handleException
    dialog_type = "info")
TypeError: generic_error_dialog() got an unexpected keyword argument 'dialog_type'
 
Local variables in innermost frame:
fs: <rhpl.exception.FileSelection instance at 0x85edf3c>
type: exceptions.NameError
text: Component: redhat-config-network
Version: 1.1.97
Summary: TB
/usr/src/build/222302-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py:198:__init__:NameError:
global name 'timeout_add' is not defined
Traceback (most recent call last):
  File "/usr/sbin/redhat-config-network-gui", line 154, in ?
    window = mainDialog()
  File
"/usr/src/build/222302-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 198, in __init__
NameError: global name 'timeout_add' is not defined
 
list: ['Traceback (most recent call last):\n', '  File
"/usr/sbin/redhat-config-network-gui", line 154, in ?\n    window =
mainDialog()\n', '
 File
"/usr/src/build/222302-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 198, in __init__\n', "NameError: global name 'timeout_add' is not defined\n"]
progname: redhat-config-network
value: global name 'timeout_add' is not defined
tb: <traceback object at 0x85ecad4>
extxt: ["NameError: global name 'timeout_add' is not defined\n"]
version: 1.1.97
t: __init__
file: /root/rh1
rc: -5
.0: (<class exceptions.NameError at 0x8117924>, <exceptions.NameError instance
at 0x85ea64c>, <traceback object at 0x85ecad4>)
tblast:
('/usr/src/build/222302-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py',
198, '__init__')
out: <closed file '/root/rh1', mode 'w' at 0x869fc20>

Comment 1 Harald Hoyer 2003-03-13 12:24:21 UTC
should be fixed..

Comment 2 Jeff Novick 2003-03-13 12:42:28 UTC
Ok, I'm sitting here scratching my head, I go through the trouble of trying to 
report a bug in detail, and I get "should be fixed.."

What do you mean "should be fixed.."? Did you somehow log into my machine and 
fix it when I wasn't looking? Probably not. So please tell me where to get the 
fix or how to fix it.



Comment 3 Harald Hoyer 2003-03-13 12:49:30 UTC
you are testing a beta, right?
well, in the final version of the beta, it should be fixed.
RAWHIDE means:
ftp.redhat.com:/pub/redhat/linux/rawhide/i386/RedHat/RPMS/
redhat-config-network-1.2.0-2.noarch.rpm
redhat-config-network-tui-1.2.0-2.noarch.rpm

Comment 4 Jeff Novick 2003-03-13 12:52:07 UTC
Thank you, I'm new to this stuff, but I'm trying.

Comment 5 Jeff Novick 2003-03-13 13:36:05 UTC
Updated the RPMs and still:

Component: redhat-config-network
Version: 1.2.0
Summary: TB /usr/src/build/226257-noarch/install/usr/share/redhat-config-
network/netconfpkg/gui/maindialog.py:198:__init__:NameError: global 
name 'timeout_add' is not defined
Traceback (most recent call last):
  File "/usr/sbin/redhat-config-network-gui", line 154, in ?
    window = mainDialog()
  File "/usr/src/build/226257-noarch/install/usr/share/redhat-config-
network/netconfpkg/gui/maindialog.py", line 198, in __init__
NameError: global name 'timeout_add' is not defined
-------
Component: redhat-config-network
Version: 1.2.0
Summary: TB /usr/lib/python2.2/site-
packages/rhpl/exception.py:280:handleException:TypeError: generic_error_dialog
() got an unexpected keyword argument 'dialog_type'
Traceback (most recent call last):
  File "/usr/sbin/redhat-config-network-gui", line 169, in ?
    handleException(sys.exc_info(), PROGNAME, PRG_VERSION)
  File "/usr/lib/python2.2/site-packages/rhpl/exception.py", line 280, in 
handleException
    dialog_type = "info")
TypeError: generic_error_dialog() got an unexpected keyword 
argument 'dialog_type'


Comment 6 Harald Hoyer 2003-03-13 14:06:48 UTC
seems like you have to update rhpl also from the same ftp location

Comment 7 Jeff Novick 2003-03-13 14:15:02 UTC
It is already installed:

rpm -Uvh rhpl-0.92-1.i386.rpm
Preparing...                ############################################
	package rhpl-0.92-1 is already installed

I got this from a mirror (carroll.cac.psu.edu) as ftp.redhat.com is reporting a 
421 Service not available.

Is this the correct version?


Comment 9 Mitsu Hadeishi 2003-05-07 14:47:54 UTC
Hello.  I'm getting the same error with a fresh install of Red Hat 9.

Comment 10 Harald Hoyer 2003-05-07 14:50:07 UTC
for RHL 9 please try the update on:
http://people.redhat.com/harald/redhat-config-network/

Comment 11 Harald Hoyer 2003-05-19 11:37:32 UTC
*** Bug 88745 has been marked as a duplicate of this bug. ***

Comment 12 Harald Hoyer 2003-05-19 11:37:40 UTC
*** Bug 87741 has been marked as a duplicate of this bug. ***

Comment 13 Harald Hoyer 2003-05-19 11:38:30 UTC
*** Bug 86228 has been marked as a duplicate of this bug. ***

Comment 14 Adam Spiers 2003-06-08 21:02:32 UTC
Upgrading to these rpms fixed it for me under RHL9, thanks.

Comment 15 Harald Hoyer 2003-09-03 12:39:20 UTC
*** Bug 103633 has been marked as a duplicate of this bug. ***

Comment 16 Harald Hoyer 2003-09-03 12:39:48 UTC
An errata has been issued which should help the problem described in the above
bug report. 
This report is therefore being closed with a resolution of ERRATA. For more
information
on the solution and/or where to find the updated files, please follow the link
below. 
You may reopen this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2003-183.html

Comment 17 Harald Hoyer 2003-09-04 08:51:50 UTC
*** Bug 103688 has been marked as a duplicate of this bug. ***

Comment 18 Harald Hoyer 2003-10-24 16:02:35 UTC
*** Bug 105778 has been marked as a duplicate of this bug. ***

Comment 19 Harald Hoyer 2003-10-30 14:24:25 UTC
*** Bug 108412 has been marked as a duplicate of this bug. ***

Comment 20 Harald Hoyer 2003-11-26 10:23:17 UTC
*** Bug 110949 has been marked as a duplicate of this bug. ***

Comment 21 Harald Hoyer 2003-12-17 08:25:57 UTC
*** Bug 112010 has been marked as a duplicate of this bug. ***

Comment 22 Harald Hoyer 2004-01-28 13:22:47 UTC
*** Bug 114395 has been marked as a duplicate of this bug. ***

Comment 23 Harald Hoyer 2004-08-16 10:18:32 UTC
*** Bug 87744 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.