Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 86058 - bash-2.05b-5 : PS1 overwrites the output-line without newline
Summary: bash-2.05b-5 : PS1 overwrites the output-line without newline
Keywords:
Status: CLOSED DUPLICATE of bug 74383
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: bash
Version: 8.0
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-13 10:33 UTC by Atuya Okudaira
Modified: 2007-04-18 16:51 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:52:11 UTC


Attachments (Terms of Use)

Description Atuya Okudaira 2003-03-13 10:33:34 UTC
Description of problem:
bash's PS1 overwrites the output-line without newline
in some environment.

Version-Release number of selected component (if applicable):
bash-2.05b-5

How reproducible:
For the RH8.0 (i386) installed with the basic language: japanese 
and with all languages,
Login X window system : Gnome or ...;
Open terminal: kterm, xterm or gnome-terminal;
type command: echo -n hello
(or helloworld.c with printf("hello"); /* without \n */)
then the output line is overwritten by PS1 of bash.

Steps to Reproduce:
1.login Gnome (lang: japanese or american english)
2.start xterm
3.type echo -n hello
    
Actual results:
[okudaira@satyros okudaira]$ echo -n hello

Expected results:
[okudaira@satyros okudaira]$ echo -n hello
hello[okudaira@satyros okudaira]$


Additional info:
[okudaira@satyros okudaira]$ echo -n hello | more
hello
[okudaira@satyros okudaira]$

'su -' or 'ssh localhost' does not reproduce the results.
bash-2.05a does not reproduce the results.

Comment 1 Tim Waugh 2003-03-13 10:39:08 UTC
Already fixed in rawhide.

*** This bug has been marked as a duplicate of 74383 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:52:11 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.