Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 86050 - Does not build on RedHat 7.2
Summary: Does not build on RedHat 7.2
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: postfix
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: John Dennis
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-13 08:38 UTC by Simon Matter
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-03-13 14:44:11 UTC


Attachments (Terms of Use)

Description Simon Matter 2003-03-13 08:38:01 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020827

Description of problem:
The new package ftp://people.redhat.com/jdennis/postfix-2.0.6-11.src.rpm doesn't
build on RedHat 7.2 because it lacks support for db4.

Version-Release number of selected component (if applicable):
postfix-2.0.6-11

How reproducible:
Always

Steps to Reproduce:
1.rpm --rebuild postfix-2.0.6-11.src.rpm
2.
3.
    

Actual Results:  It doesn't build because db4-devel is missing.

Expected Results:  The package should have used db3-devel instead.

Additional info:

Of course, this is not a bug because the package isn't intended to build on
RedHat 7.x. However this small patch makes it build on 7.x and 8.x.

--- postfix-2.0.6-11.src/postfix.spec   Mon Mar 10 23:38:43 2003
+++ /usr/src/redhat/SPECS/postfix.spec  Thu Mar 13 08:51:56 2003
@@ -40,6 +40,9 @@
 %define maildrop_group postdrop
 %define maildrop_gid   %{POSTDROP_GID}
 
+# Do we use db3 or db4 ? If we have db4, assume db4, otherwise db3.
+%define dbver %(eval "rpm -q --quiet db4 && echo db4 || echo db3")
+
 Name: postfix
 Group: System Environment/Daemons
 URL: http://www.postfix.org
@@ -70,7 +73,7 @@
 BuildRoot: %{_tmppath}/%{name}-buildroot
 
 # Determine the different packages required for building postfix
-BuildRequires: gawk, perl, sed, ed, db4-devel, pkgconfig
+BuildRequires: gawk, perl, sed, ed, %{dbver}-devel, pkgconfig
 
 %if %{LDAP}
 BuildRequires: openldap >= 1.2.9, openldap-devel >= 1.2.9

Comment 1 John Dennis 2003-03-13 14:44:11 UTC
Thanks!!! I've added your fix to the spec file.


Note You need to log in before you can comment on or make changes to this bug.