Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 86030 - RPM GUI does not work
Summary: RPM GUI does not work
Keywords:
Status: CLOSED DUPLICATE of bug 74877
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-packages
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-12 17:45 UTC by Maurice Meneguzzi
Modified: 2007-04-18 16:51 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:52:10 UTC


Attachments (Terms of Use)

Description Maurice Meneguzzi 2003-03-12 17:45:38 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
rpm works in command line mode but not in GUI mode.
When I click on RedHat --> SystemSettings --> Packages (logged in as root), the
window opens witn the message "Cheking for installed packages" and then closes.
Here are the messages in the system log:

Mar 12 12:02:50 localhost kernel: parport0: PC-style at 0x378 (0x778)
[PCSPP,TRISTATE,EPP]
Mar 12 12:02:50 localhost kernel: parport0: irq 7 detected
Mar 12 12:05:51 localhost kernel: parport0: PC-style at 0x378 (0x778)
[PCSPP,TRISTATE,EPP]
Mar 12 12:05:51 localhost kernel: parport0: irq 7 detected
Mar 12 12:09:52 localhost kernel: parport0: PC-style at 0x378 (0x778)
[PCSPP,TRISTATE,EPP]
Mar 12 12:09:52 localhost kernel: parport0: irq 7 detected


Version-Release number of selected component (if applicable):
rpm-4.1-1.06    kernel-2.4.18-14

How reproducible:
Always

Steps to Reproduce:
1.click on RedHat --> SystemSettings --> Packages
2.
3.
    

Additional info:

Comment 1 Jeremy Katz 2003-03-13 20:12:39 UTC
If you run 'redhat-config-packages' from a terminal, what sort of output do you
get? 

Comment 2 Jeremy Katz 2003-03-13 21:47:11 UTC
From: 	meneguzzi <meneguzzi@worldnet.att.net>
To: 	katzj@redhat.com
Subject: 	Bug 86030
Date: 	13 Mar 2003 16:44:40 -0500	
Hello,

When I run "redhat-config-packages" the GUI window opens and closes, and
here is the message on the terminal:


# redhat-config-packages
Traceback (most recent call last):
  File "/usr/share/redhat-config-packages/MainWindow.py", line 163, in ?
    comps = im.readCompsViaMethod(hdlist, progress.update)
  File "/usr/share/redhat-config-packages/method.py", line 488, in
readCompsViaMethod
    update_method = update_method)
  File "/usr/share/redhat-config-packages/comps.py", line 387, in
__init__
    self.readCompsFile(file, self.packages)
  File "/usr/share/redhat-config-packages/comps.py", line 471, in
readCompsFile
    self.setupStateDicts(packages)
  File "/usr/share/redhat-config-packages/comps.py", line 420, in
setupStateDicts
    for prov in h[rpm.RPMTAG_PROVIDES]:
TypeError: iteration over non-sequence



*** This bug has been marked as a duplicate of 74877 ***

Comment 3 Red Hat Bugzilla 2006-02-21 18:52:10 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.