Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85947 - Installer does not list additional "driver disk" modules
Summary: Installer does not list additional "driver disk" modules
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 8.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-11 11:48 UTC by Renato Bonomini
Modified: 2007-04-18 16:51 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-03-11 17:34:53 UTC


Attachments (Terms of Use)

Description Renato Bonomini 2003-03-11 11:48:45 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
(During installation via floppy disk on a laptop without cdrom but pccard nic)

The additional driver disk image does not contain a valid "modinfo" description
file, it seems to be the normal "modinfo" file contained in the usual install image.

The module for my network card is present (3c574_cs), but still after manually
adding an entry on the "modinfo" file on the pcmciadd.img driver disk hte ds.o
module does not load correctly.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.create bootnet.img and pcmciadd.img disks
2.install with linux dd to load the driver disk
3.the driver list is not consistent with the pcmciadd.img disk
    

Actual Results:  No way to install with laptop via network

Additional info:

After manually changing the modinfo file on the pcmciadd.img disk, I can choose
my pccard nic, but module ds.o does not load correctly, I presume a missing
option to ds.o. 


The log says
* inserted pcmcia_core.o
/tmp/ds.o: init modules:
Hint; insmod errors can be caused by incorrect module parameters, including
invalid IO or IRQ parameters
* failed to insert /tmp/ds.o

Comment 1 Jeremy Katz 2003-03-11 17:34:53 UTC
This should be better in phoebe and beyond.  PCMCIA was a bizarre case
previously that wasn't really directly handled by the loader.


Note You need to log in before you can comment on or make changes to this bug.