Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85944 - ntp daemon not started on unconnected machines
Summary: ntp daemon not started on unconnected machines
Keywords:
Status: CLOSED DUPLICATE of bug 82200
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ntp
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-11 09:45 UTC by Reuben Thomas
Modified: 2007-04-18 16:51 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:52:09 UTC


Attachments (Terms of Use)

Description Reuben Thomas 2003-03-11 09:45:40 UTC
Description of problem:

Before /etc/init.d/ntp starts up the ntp server, it tries to run ntpdate. If this fails, it doesn't start the server. Hence, on a machine that doesn't have a permanent internet connection (or more specifically, isn't connected at boot time), the daemon won't be run.

Version-Release number of selected component (if applicable):

4.1.1a

How reproducible:

Always

Steps to Reproduce:
1. Install ntp and activate it, then boot on a machine without a net connection
2.
3.
    
Actual results:

The "synchronizing with time server line" will say "failed" (correctly), and the daemon will not be started.

Expected results:

Immediate synchronisation should fail, but the daemon should still be started, so that when a net connection is made, the time server can be reached and used for synchronisation.

Additional info:

Comment 1 Harald Hoyer 2003-03-11 12:01:31 UTC
resolved in the latest rawhide versions... thx

*** This bug has been marked as a duplicate of 82200 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:52:09 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.