Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85936 - Kickstart install fails after selecting minimal
Summary: Kickstart install fails after selecting minimal
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-kickstart
Version: 8.0
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-11 02:26 UTC by Need Real Name
Modified: 2007-04-18 16:51 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-03-20 21:13:23 UTC


Attachments (Terms of Use)
dump file (deleted)
2003-03-11 02:28 UTC, Need Real Name
no flags Details

Description Need Real Name 2003-03-11 02:26:23 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
using Kickstart Configurator if I make a kickstart config file without selecting
and packages the install will run successfully. If I select the "Minimal"
package option under Miscellaneous the install fails.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run redhat-config-kickstart
2.select http installation method
3.under package selection check only "Minimal"
4.save file to network install floppy
5.boot linux ks=floppy
    

Additional info:

Comment 1 Need Real Name 2003-03-11 02:28:25 UTC
Created attachment 90546 [details]
dump file

Comment 2 Mike McLean 2003-03-11 14:54:39 UTC
...
  File "/usr/src/build/148651-i386/install//usr/lib/anaconda/kickstart.py", line
1119, in setGroupSelection
  File "/usr/src/build/148651-i386/install//usr/lib/anaconda/comps.py", line
580, in __getitem__
KeyError: Minimal
...

Looks like redhat-config-kickstart is putting the wrong entry in %packages.  It
should be '@ Base', not '@ Minimal' for minimal installs.


Comment 3 Brent Fox 2003-03-20 21:13:23 UTC
I have removed the Minimal section since it is no longer in comps.xml.  It has
been replaced by "Base" in the comps.xml file but it doesn't make sense to show
that in redhat-config-kickstart since Base is always installed.  

This report is basically a dupe of bug #77126.  The change should appear in
redhat-config-kickstart-2.3.3-5 and later.


Note You need to log in before you can comment on or make changes to this bug.