Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85919 - Upgrading postgresql erased my databases
Summary: Upgrading postgresql erased my databases
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: postgresql
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Andrew Overholt
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-10 20:57 UTC by Glen
Modified: 2007-04-18 16:51 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-03-12 22:10:49 UTC


Attachments (Terms of Use)

Description Glen 2003-03-10 20:57:32 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
I'm not sure whether this counts as a bug or if it's just foolishness on my
part.  Anyway I upgraded my postgresql packages on two of my machines using an
'rpm -Fvh *'.  After that the databases on one of the machines seems to have
dissapeared.  The second machine seems fine though.  Both machines had roughly
the exact same postgresql setup so it makes no sense how one is trashed while
the other one isn't.

On the machine the databases disappeared from, if I try and run 'psql template1'
it tells me this:
psql: FATAL 1:  Database "template1" does not exist.
        The database subdirectory '/var/lib/pgsql/data/base/1' is missing.

The way I understand it the template1 database should always be there no matter
what.  And in fact the whole /var/lib/pgsql/data/base directory is missing, not
just a directory under it.

Anyway, like I said, I'm not sure if this counts as a bug or what, but that's
what happened.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try


Additional info:

Comment 1 Andrew Overholt 2003-03-12 20:54:04 UTC
Hmm.  Can you tell me what packages you upgraded (ie. which ones, specifically)?
 Also, is it possible that your data directory was something other than
/var/lib/pgsql with your previous setup and the init script got overwritten? 
From what version(s) were you upgrading?  And to what?

Comment 2 Glen 2003-03-12 21:50:28 UTC
Darn it, I'm sorry to bother you guys.  It turns out that prior to the upgrade
my /var/lib/pgsql directory was actually a link to another location.  I still
find it rather odd though that after the upgrade there was no template1 database.

Comment 3 Andrew Overholt 2003-03-12 22:10:49 UTC
The database location is not initialized until running `/etc/init.d/postgresql
start` (or `service postgresql start`), so unless this was done after the
upgrade (with the link removed), it would not have been created.


Note You need to log in before you can comment on or make changes to this bug.