Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85894 - ntpd init script ignores hosts containing 127.* anywhere in address
Summary: ntpd init script ignores hosts containing 127.* anywhere in address
Keywords:
Status: CLOSED DUPLICATE of bug 82713
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ntp
Version: 9
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-10 14:41 UTC by Matthew Miller
Modified: 2008-01-17 17:49 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:52:09 UTC


Attachments (Terms of Use)

Description Matthew Miller 2003-03-10 14:41:46 UTC
The ntpd init script contains a simple regex to avoid punching holes for
localhost in the firewall. It does this by deleting any line that contains
127.*. As you can probably see plainly once this is pointed out :) this is a bit
*too* simple -- a host like 192.169.127.14 would get deleted too. The expression
needs to be tightened to match only hosts that *begin* with 127.

Comment 1 Harald Hoyer 2003-03-10 14:47:42 UTC
I know, I know... fix didn't make it in the final version..

Comment 2 Harald Hoyer 2003-03-10 14:49:07 UTC

*** This bug has been marked as a duplicate of 82713 ***

Comment 3 Red Hat Bugzilla 2006-02-21 18:52:09 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.