Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85868 - rpm --rebuilddb db4 error(11) issue after installing phoebe
Summary: rpm --rebuilddb db4 error(11) issue after installing phoebe
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: rpm
Version: phoebe
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-09 22:38 UTC by Amoor Avakian
Modified: 2005-10-31 22:00 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-03-10 16:17:32 UTC


Attachments (Terms of Use)

Description Amoor Avakian 2003-03-09 22:38:15 UTC
Description of problem:

I had RH 8, then i upgraded to Phoebe, the rpm database started to give
problems, i had to follow the instructions on this website :
http://www.rpm.org/hintskinks/repairdb/ but that did not work as when i ran "rpm
--rebuilddb" command i got this error :

error: db4 error(11) from dbenv->open: Resource temporarily unavailable

The same error is thrown by Ximian Red-Carpet AFTER the upgrade to Phoebe,
before it worked fine.  Thanks.

Comment 1 Jeff Johnson 2003-03-10 16:17:32 UTC
rpm-4.2 uses posix mutexes for locking, so you need to
remove the database environment
    rm -f /var/lib/rpm/__db*

Red Carpet uses librpm404, which does not use posix mutexes,
so you are going to have interoperability problems until
Red Carpet starts to use rpm-4.1 or later.


Note You need to log in before you can comment on or make changes to this bug.