Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85864 - sendmail fails to deliver locally submitted email
Summary: sendmail fails to deliver locally submitted email
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sendmail
Version: 8.0
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Florian La Roche
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-09 19:33 UTC by Gerald Teschl
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-03-09 20:03:59 UTC


Attachments (Terms of Use)

Description Gerald Teschl 2003-03-09 19:33:49 UTC
Description of problem:
I noted that emails sent via squirrelmail to local users get
lost. So I looked at the problem more closely and it looks
like sendmail fails to deliver any locally submitted email
to local users.

Email from outside are delivered just fine.


How reproducible:
100%

Steps to Reproduce:
I tried to send an email to a local user using
a) telnet localhost 25
b) mail
The mail is accepted by sendmail and corresponding log entries are written:

Mar  9 20:24:18 keen sendmail[10823]: h29JOH3I010823: from=root, size=30,
class=0, nrcpts=1, msgid=<200303091924.h29JOH3I010823@keen.esi.ac.at>,
relay=root@localhost
Mar  9 20:24:18 keen sendmail[10826]: h29JOH3I010823: to=gerald, ctladdr=root
(0/0), delay=00:00:00, xdelay=00:00:00, mailer=local, pri=30026, dsn=2.0.0,
stat=Sent

However, the mail never shows up in the mailbox of the user!? Moreover,
the mailq is empty, so it is not hanging somewhere.

Comment 1 Gerald Teschl 2003-03-09 20:03:59 UTC
This strange. I just did

rpm -e --nodeps sendmail
rm -rf /etc/mail
rpm -i sendmail-8.12.8-1.80.i386.rpm

copied my config files back and now it works just fine!?
I don't get it....


Note You need to log in before you can comment on or make changes to this bug.