Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85863 - sm-client fails to write pid file
Summary: sm-client fails to write pid file
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sendmail
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Florian La Roche
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-09 19:21 UTC by Gerald Teschl
Modified: 2007-04-18 16:51 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-03-09 20:07:01 UTC


Attachments (Terms of Use)

Description Gerald Teschl 2003-03-09 19:21:40 UTC
Description of problem:
I noted that sendmail fails to write the pid file for sm-client:

Mar  9 20:08:12 keen sm-msp-queue[10674]: unable to write
/var/run/sm-client.pid: Permission denied

Hence the corresponding process does not get stopped by
the initscript.


Version-Release number of selected component (if applicable):
sendmail-8.12.8-1.80

How reproducible:
100%

Steps to Reproduce:
1. service sendmail start
2. cat /var/run/sm-client.pid
3.
    
Actual results:
pid file is empty

Expected results:
pid written to pid file

Additional info:
1) ervice sendmail restart will fail to stop sm-client.
2) removing the "touch /var/run/sm-client.pid" line from the
init script seems to fix the problem.

Comment 1 Gerald Teschl 2003-03-09 20:06:52 UTC
Must have been related to my strange problems reported in #85864.
After reinstalling the sendmail rpm it works fine now.


Note You need to log in before you can comment on or make changes to this bug.