Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85862 - Anaconda cannot allocate memory and exits
Summary: Anaconda cannot allocate memory and exits
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-09 19:17 UTC by Derek
Modified: 2007-04-18 16:51 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-03-09 22:14:46 UTC


Attachments (Terms of Use)

Description Derek 2003-03-09 19:17:42 UTC
Description of problem:
When I attempt to install R.H. Linux on a computer with 80 MB of RAM, anaconda 
reports that it cannot allocate memory after it finishes setting up the RPM 
transactions.

Version-Release number of selected component (if applicable): Red Hat Linux 8.0


How reproducible:Always


Steps to Reproduce:
1. Begin Installation
2. Wait for anaconda to finish setting up RPM transactions
3. See The Error
    
Actual results:
Anaconda reports that it cannot allocate enough memory and exits.

Expected results:
Anaconda will start installing Linux.

Additional info:

Comment 1 Derek 2003-03-09 22:14:46 UTC
OK, heres what the problem was:

When I was partitioning my hard drive, I didn't set a swap partition.  
Apparently, anaconda ran out of memory after it set up the RPM transactions.  
Just a note, Red Hat developers might want to put some better memory handlers 
into anaconda for the next release.


Note You need to log in before you can comment on or make changes to this bug.