Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85857 - nv driver crashes (gives a black screen)
Summary: nv driver crashes (gives a black screen)
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86-Servers
Version: phoebe
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-09 16:58 UTC by Philip Van Hoof
Modified: 2007-04-18 16:51 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-03-10 10:27:13 UTC


Attachments (Terms of Use)

Description Philip Van Hoof 2003-03-09 16:58:07 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20021203

Description of problem:
The nv driver hangs. I have been using the nvidia drivers from nvidia.com on my
RedHat 8.0 installation. When I upgraded to the current beta (Phoebe) and
(manually) set the driver from "nvidia" to "nv", I got a black screen and
everything hangs (going back to a console is impossible). My nvidia card is a
Geforce 2 MX.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install rh8.0
2. Install the nvidia drivers from nvidia.com (which is what a lot users do)
3. Install phoebe
4. Set "nvidia" back to "nv" in the XF86Config file
5. startx

    

Actual Results:  Black screen.. everything hangs

Expected Results:  X should have started with the opensource nvidia-driver

Additional info:

Comment 1 Mike Chambers 2003-03-09 19:27:08 UTC
Please attach your XFree config & log files.  Also, give the output of rpm -qa 
| grep kernel, rpm -qa | grep NIVIDIA and uname -a.

Comment 2 Mike A. Harris 2003-03-10 10:27:13 UTC
Nvidia's drivers purposefully remove or rename files that are part of
our XFree86 packaging once they are installed.  As such, the only way
to ensure that you have the exact files installed that are part of
Red Hat Linux, is to reinstall the XFree86 package after removing the
Nvidia binary drivers.

Red Hat does not support systems which use Nvidia's binary drivers, nor
those which have had files modified or removed during the installation
of those drivers.

Furthermore, since Nvidia's technical specifications are not available
to the public, nor to Red Hat freely, nor under any form of NDA, there
is nothing that Red Hat can do to fix bugs in the "nv" driver, even if
it is nonfunctional on a clean installation.

If the "nv" driver continues to cause problems on a clean OS installation,
please report this problem to xfree86@xfree86.org, so that the driver
maintainer(s) at Nvidia whom have access to the hardware specifications
can investigate the problem and perhaps fix the bugs that may be present
in the "nv" driver.


Note You need to log in before you can comment on or make changes to this bug.