Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85852 - Entering a directory does not update the treeview
Summary: Entering a directory does not update the treeview
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: nautilus
Version: phoebe
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact: Jay Turner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-09 12:42 UTC by Mikael Carneholm
Modified: 2015-01-08 00:04 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-03-11 14:25:54 UTC


Attachments (Terms of Use)
Image of nautilus tree view before entering a directory (deleted)
2003-03-09 12:44 UTC, Mikael Carneholm
no flags Details
Image of nautilus tree view after entering a directory (deleted)
2003-03-09 12:45 UTC, Mikael Carneholm
no flags Details

Description Mikael Carneholm 2003-03-09 12:42:00 UTC
Description of Problem:
The treeview in the side pane does not follow when changing directory in the
main (right hand) icon/list view.

Steps to reproduce the problem:
1. Make sure the side pane is visible, and change to tree view in the chooser.
2. Click the icon for, lets say, /usr.
3. Expand /usr by clicking the arrow besides the icon, so that the
subdirectories to /usr are also visible in the tree view.
4. In the main (right hand) view, double click a directory icon (say, the
libexec directory icon)

Actual Results:
The treeview still marks the place where you stood before entering the
directory, i.e. it marks /usr.

Expected Results:
The treeview should mark the directory you just entered, i.e. /usr/libexec.

How often does this happen?
Always.

Additional Information:
See attached screenshots.

Comment 1 Mikael Carneholm 2003-03-09 12:44:19 UTC
Created attachment 90531 [details]
Image of nautilus tree view before entering a directory

Comment 2 Mikael Carneholm 2003-03-09 12:45:35 UTC
Created attachment 90532 [details]
Image of nautilus tree view after entering a directory

Comment 3 Alexander Larsson 2003-03-11 14:25:54 UTC
It's not meant to do that. The tree view is a completely separate view.

Comment 4 Mikael Carneholm 2003-03-12 00:42:30 UTC
Really? If the tree view and the main view are totally independent, then why
does the main view update when selecting a directory in the tree view? 

Has there been any usability studies on this subject?

- Mikael

Comment 5 Alexander Larsson 2003-03-12 09:15:08 UTC
I don't know if Eazel did a usability study on this. 

I can easily think of situations when this change would be irritating:
Say you're using the tree view as a drop target, and are navigating the main
view and copying things from various directories to the destination. Having the
treeview scroll when you change directory in the main view would be irritating.

When would it be useful?

Comment 6 Mikael Carneholm 2003-03-12 11:41:15 UTC
Who said anything about scrolling when using it as a drop target?

With usability study I was refering to something like the Gnome Usability Study
report - sadly, it doesn't mention the tree view at all
(http://developer.gnome.org/projects/gup/ut1_report/file_management.html). 

I admit it's a long time since I used windows (about 1,5 years now) meaning I
may very well be mistaken, but doesn't windows explorer work like this? And how
does the K file manager work? (Never use KDE either and don't bother installing
it just to check this, but it would be interesting to know for comparison) 

- Mikael

Comment 7 Alexander Larsson 2003-03-13 09:08:12 UTC
If you change the tree view (e.g. expand a node) you will certainly scroll the
view. At least if you're positioned under the node that was expanded.



Note You need to log in before you can comment on or make changes to this bug.