Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85848 - test-4.1.1 dependency conflict with redhat-rpm-config
Summary: test-4.1.1 dependency conflict with redhat-rpm-config
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm
Version: 8.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-09 11:33 UTC by Barry K. Nathan
Modified: 2007-04-18 16:51 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-03-10 16:13:05 UTC


Attachments (Terms of Use)

Description Barry K. Nathan 2003-03-09 11:33:10 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030308

Description of problem:
The RPM test-4.1.1 packages fail to properly install onto a Red Hat 8.0 system
due to a dependency (version) problem involving redhat-rpm-config-8.0-1.

How reproducible:
Always

Steps to Reproduce:
Method A:
1. Set up Red Hat 8.0 system
2. Try to install the test-4.1.1 RPM packages from the command line (e.g., rpm
-Fvh *8x.i386.rpm)

Method B:
1. Set up a Red Hat 8.0 system
2. Set up a server (e.g., Current) for up2date, with all errata
3. Update the RH 8.0 system from the server (apply all errata).
4. Add the test-4.1.1 packages to the server
5. Attempt to update the 8.0 client again.

Actual Results:  from up2date:
Testing package set / solving RPM inter-dependencies...
There was a package dependency problem. The message was:

Unresolvable chain of dependencies:
redhat-rpm-config-8.0-1                  requires rpmbuild(VendorConfig) <= 4.1


from command line:
error: Failed dependencies:
        rpmbuild(VendorConfig) <= 4.1 is needed by (installed)
redhat-rpm-config-8.0-1


Expected Results:  Successful installation of new RPM test packages, and
resolution of RPM freeze/hang problems.

Additional info:

I don't knoe if this is the fault of the new RPM packages or the old
redhat-rpm-config package. Also, I'm not sure whether to file this against 8.0
or rawhide. Feel free to change the component or version if I blew this.

Comment 1 Jeff Johnson 2003-03-10 16:13:05 UTC
Ah yes, another place where 4.1 needs to be hard wired.

The dependency in the rpm-build package was
    Provides:  rpmbuild(VendorConfig) = %{version}

Fixed in CVS, will be in both rpm-4.2 and rpm-4.1.1 final.

Thanks for the report.


Note You need to log in before you can comment on or make changes to this bug.