Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85843 - shutdown -h actually reboots
Summary: shutdown -h actually reboots
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: kernel
Version: phoebe
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-09 05:16 UTC by Michael Wardle
Modified: 2007-04-18 16:51 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-03-23 05:58:38 UTC


Attachments (Terms of Use)

Description Michael Wardle 2003-03-09 05:16:44 UTC
Description of problem:
When I attempt to shut down the system using "shutdown -h now" or
the "Shut Down" menu option in GDM, the system reboots rather than
powering down.

Version-Release number of selected component (if applicable):
SysVinit-2.84-13

How reproducible:
Always

Additional info:
This only began happening recently, after installing Red Hat
Linux 8.0.94 (Phoebe 3), however at a similar time I also flashed
my system's BIOS to the latest version.

My mainboard is made by MSI, uses a AMI BIOS, and uses a KT266
chipset.

The Shut Down option in Windows XP causes the system to correctly
power down as expected.

Comment 1 Bill Nottingham 2003-03-10 21:36:03 UTC
This is an interaction between the kernel's reboot code and your BIOS, and is
very likely caused by your recent BIOS change.

Comment 2 Michael Wardle 2003-03-23 05:58:38 UTC
Flashing the BIOS had changed the "Power Management/APM" menu item to "Off".
After reenabling this option, shutdown -h powers off the machine as it once did.

I wouldn't expect to be able to power off the system without this enabled,
despite what Windows seemed to do.



Note You need to log in before you can comment on or make changes to this bug.