Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85832 - unable to input after selection window
Summary: unable to input after selection window
Keywords:
Status: CLOSED DUPLICATE of bug 78017
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kinput2
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Akira TAGOH
QA Contact: Bill Huang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-08 16:49 UTC by Kazutoshi Morioka
Modified: 2007-04-18 16:51 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-21 18:52:08 UTC


Attachments (Terms of Use)

Description Kazutoshi Morioka 2003-03-08 16:49:12 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.8 (X11; Linux i686; U;) Gecko/20030212

Description of problem:
While typing KANJI characters with kinput2,
We will accidentaly unable to input after selection window is popped up.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Login with japanese language setting with canna and kinput2.
2. Open gnome-terminal and type "cat" and hit ENTER.
3. Type Shift-SPACE key, kinput2 window is shown.
4. Type keys, "k", "a", "n", "j", "i".
5. Type SPACE key three times, selection window is popped up.
6. Type ENTER and Shift-SPACE.
    

Actual Results:  Typed and selected KANJI characters are disappear.
Kinput2 window is still there, but unable to input KANJI character.
Shift-SPACE key can't open nor close kinput2 window anymore.
It's impossible to get out this situation until closing application itself.

Expected Results:  Selected KANJI characters are appear, and kinput2 window closes.

Additional info:

This can be caused with any other applications,
for example, galeon, mozilla, gnumeric, OpenOffice.org, ...
See below. This is a support page of SuSE.
http://lists.suse.com/archive/m17n/2002-May/0055.html
According to this page, this problem is caused by kinput2 windows
to get unneeded input-focus.
The workaround in this page is perfect for me.
All japanese user really require to avoid this bug to live with
Red Hat Linux as a desktop system.
Please put this in initial setting of kinput2.

Comment 1 Akira TAGOH 2003-04-21 08:53:00 UTC

*** This bug has been marked as a duplicate of 78017 ***

Comment 2 Red Hat Bugzilla 2006-02-21 18:52:08 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.