Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85819 - Nautilus does not revert to default window size if closed whilst maximized
Summary: Nautilus does not revert to default window size if closed whilst maximized
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: nautilus
Version: 9
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact: Jay Turner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-08 06:47 UTC by Elton Woo
Modified: 2015-01-08 00:04 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-05-27 11:51:45 UTC


Attachments (Terms of Use)
screen captures of windows opened and closed (deleted)
2003-03-12 21:32 UTC, Elton Woo
no flags Details

Description Elton Woo 2003-03-08 06:47:10 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030221

Description of problem:
If one or more windows of Nautilus are opened and _at least one_
is maximized, then closed, subsequent 'new' windows will load 
in maximized state, and 'refuse' to return to the default size.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Open one or more Nautilus windows. Maximize _at least_ one window
2. Close maximized window(s) whilst in that state.
3. Open new windows
    

Actual Results:  Newly opened windows open maximized, and will not return to
"default"
(i.e. "unmaximized") state. They have to be resized manually.

Expected Results:  New windows should open at default size (e.g. 1/3 full-screen
size).

Additional info:

This behavoir was also observed in the two previous Phoebe betas, and
persists in Phoebe3 / RH 8.0.94.

Video subsystem: Viewsonic 17" monitor
JATON 3DForce B-32 Plus AGP video card (32Mb SGRAM) 
Resolution: 1024 x 768 x 32-bit.

All current (to Feb. 22) updates have been applied from rawhide.
Kernels in use:
kernel-2.4.20-2.48
kernel-2.4.20-2.54

Comment 1 Alexander Larsson 2003-03-11 14:17:26 UTC
I guess nautilus shouldn't store the last window size if the window is maximized.


Comment 2 Elton Woo 2003-03-11 17:13:12 UTC
Let me repeat this: 
1) Open _two or more_ Nautilus windows. 
2) Maximize *one* window 
3) Close the maximized one *first*, THEN 
4) Close the other window(s) which are NOT maximized. 
5) Open a new window. 
 
Result: Newly opened window(s) start up maximized. 
 
EXPECTED Result: Newly opened windows should start up 
_UN-maximized_ 
 
#COMMENT: 
                    Shouldn't the new window remember the _last state_? 
i.e. the unmaximized state, since that was the _last size_ when the 
*last opened* window was closed? 
 
IMHO, if the _last opened_ window were maximized, and the _last one_ to 
be closed _while in that state_, then and only then, would it be logical for  
_newly opened windows to start up maximized_,  
not vice-versa, as is now the case ... 
 

Comment 3 Alexander Larsson 2003-03-12 09:09:41 UTC
Did the two windows both show the same location? Window geometry is stored
per-directory.

Anyway, this is fixed in gnome cvs by never storing the geometry of a maximized
window. That makes no sense anyway.


Comment 4 Elton Woo 2003-03-12 21:32:31 UTC
Created attachment 90577 [details]
screen captures of windows opened and closed

I hope this can more clearly illustrate what happens (a "picture being
worth a thousand words"... in effect).

Comment 5 Alexander Larsson 2003-03-13 09:12:27 UTC
In other words, it behaves exactly like i said, and is now fixed in cvs.

Comment 6 Alexander Larsson 2003-05-27 11:51:45 UTC
fixed in rawhide.



Note You need to log in before you can comment on or make changes to this bug.