Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85818 - gnome sound recorder creates 0 byte files in Phoebe 3/ RH 8.0.94
Summary: gnome sound recorder creates 0 byte files in Phoebe 3/ RH 8.0.94
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnome-media
Version: 9
Hardware: athlon
OS: Linux
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: Jay Turner
: 89568 91636 (view as bug list)
Depends On:
Blocks: CambridgeTarget
TreeView+ depends on / blocked
Reported: 2003-03-08 06:22 UTC by Elton Woo
Modified: 2015-01-08 00:04 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2006-02-21 18:52:08 UTC

Attachments (Terms of Use)
email exchange to/from developer of application (deleted)
2003-03-08 06:23 UTC, Elton Woo
no flags Details

Description Elton Woo 2003-03-08 06:22:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030221

Description of problem:
Recording a file with Gnome Sound Recorder, when user selects
"save" or "save as" a 0 byte file is created!

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Start Gnome Sound recorder with input from microphone or line-in
2. Increase speaker volume, so that input can be verified
Start recording and after "n" minutes, save the new recording
3. Select the saved file, and attempt to play it.    

Actual Results:  Gnome Sound recorder *consistently* creates a 0 byte file.

Expected Results:  A file should be created in a size appropriate to the length and 
quality of the recording.

Additional info:

This problem was observed in Phoebe 2 (RH 8.0.93), and still 
exists in Phoebe 3 (RH 8.0.94). The most current updates
from rawhide (to FEB. 22)have been applied to my system.

ALSA (from freshrpms) is installed:


using either of the following kernels
kernel-2.4.20-2.48 (Phoebe 3 default)
kernel-2.4.20-2.54 (most current from rawhide)

I have also contacted the author of Gnome Sound Recorder.
(Kindly refer to attachment).

Comment 1 Elton Woo 2003-03-08 06:23:33 UTC
Created attachment 90529 [details]
email exchange to/from developer of application

Comment 2 adam allen 2003-03-08 18:52:44 UTC
I can confirm this also occurs on my system- which is vanilla Phoebe3 without ALSA.

Comment 3 adam allen 2003-03-10 21:05:19 UTC
Tried the steps described in  attachment 90529 [details] with the following output.
Soundcard is an AWE-64. The result is a 4K wav file, which fails to play, the
command returns to the command prompt a few a few seconds.

[root@blackswan root]# gst-launch osssrc ! wavenc ! filesink location=temp-test.wav
INFO ( 2322: 0) Initializing GStreamer Core Library version 0.6.0
INFO ( 2322: 0) CPU features: (0c040843) MMX
registry: loaded user_registry in 0.000337 seconds
registry: loaded global_registry in 0.298376 seconds
GStreamer-INFO: 0 live buffer(s)
GStreamer-INFO: 0 live bufferpool(s)
GStreamer-INFO: 0 live event(s)
RUNNING pipeline
ERROR: /pipeline0/osssrc0: error reading data (Input/output error)
execution ended after 3 iterations (sum 5513902000 ns, average 1837967333 ns,
min 510000 ns, max 4999501000 ns)
GStreamer-INFO: 0 live buffer(s)
GStreamer-INFO: 0 live bufferpool(s)
GStreamer-INFO: 0 live event(s)

Comment 4 Havoc Pennington 2003-04-24 16:10:59 UTC
*** Bug 89568 has been marked as a duplicate of this bug. ***

Comment 5 Havoc Pennington 2003-08-06 21:18:50 UTC
*** Bug 91636 has been marked as a duplicate of this bug. ***

Comment 6 Elton Woo 2003-11-02 21:58:15 UTC
I have just tried, and though it no longer creates a 0 byte file, the
Gnome Sound Recorder (version 2.4.0) locks up when recording under KDE,
and abends when playback of a recorded file is attempted under Gnome
(Fedora Core 1).
versions: gnome-audio-1.4.0-6, gnome-media-2.4.0-2, gnome-utils-2.4.0-1

Comment 7 Ben Woodard 2004-01-26 00:15:48 UTC
RHL 8 is no longer a supported product. This bug still exists in RHEL3
and so I'm closing this bug as a dup of the version of the bug for RHEL3.

*** This bug has been marked as a duplicate of 106104 ***

Comment 8 Red Hat Bugzilla 2006-02-21 18:52:08 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.