Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85797 - when trying to change configuration, print manager reports "tray empty"
Summary: when trying to change configuration, print manager reports "tray empty"
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: cups
Version: 9
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-07 21:01 UTC by Elton Woo
Modified: 2007-04-18 16:51 UTC (History)
1 user (show)

Fixed In Version: 1.1.19-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-05-29 21:38:11 UTC


Attachments (Terms of Use)

Description Elton Woo 2003-03-07 21:01:06 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030221

Description of problem:
While printing, I attempted to change the printer configuration via
printman. This returns an erroneous message: "tray empty".

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Send a job to print, and *while the job is printing*
2. Start Print Manager
3. Try changing the printer, and / or printer options
    

Actual Results:  Printman reports "tray empty!"

Expected Results:  Printman should say: "printer IN USE"

Additional info:

If this message is sent from a remote printer (mine is local),
it would be "mis-informative".

Comment 1 Tim Waugh 2003-03-07 21:29:22 UTC
This message originates in CUPS.  I've seen it too actually.

Comment 2 Tim Waugh 2003-03-07 21:32:33 UTC
USB printer?  Now that I look this seems to be due to the kernel:

backend/usb.c:237:
  if (ioctl(fd, LPGETSTATUS, &status) == 0)
  {
    fprintf(stderr, "DEBUG: LPGETSTATUS returned a port status of %02X...\n",
status);
                                                                                
    if (status & LP_NOPA)
      fputs("WARNING: Media tray empty!\n", stderr);
    else if (status & LP_ERR)
      fputs("WARNING: Printer fault!\n", stderr);
    else if (status & LP_OFFL)
      fputs("WARNING: Printer off-line.\n", stderr);
  }

So perhaps the kernel is returning the wrong values?

I've seen this message with a USB-connected HP DeskJet 990C.  What printer are
you using, and with what connection?

Comment 3 Elton Woo 2003-03-07 22:00:38 UTC
I am using a Lexmark Z53 connected via an Atmel 4-port USB hub. Default kernel 
is kernel-2.4.20-2.48 and I am currently logged in using kernel-2.4.20-2.54. The problem 
occurs with either kernel. I keep switching between these kernels due to ongoing problems 
with CD burning. 
 

Comment 4 Tim Waugh 2003-05-28 09:30:15 UTC
Think this might be fixed in CUPS 1.1.19.

Comment 5 Elton Woo 2003-05-28 15:44:07 UTC
now the Printer Configuration app (print manager) just hangs with the message: 
"Loading printer information, Please wait..." (and wait, and wait, and *wait*.....).  
I'm forced to kill the print manager session. This happens either when loading 
_during_ a print job, or without any print job in the queue. 
kernel-2.4.20-9.athlon.rpm in now the default, with the following package 
versions 
cups-1.1.19-0.rc5.3.i386.rpm 
cups-libs-1.1.19-0.rc5.3.i386.rpm 
printman-0.0.1-0.20021202.14.i386.rpm 

Comment 6 Tim Waugh 2003-05-28 16:38:14 UTC
What version of redhat-config-printer?  Run it from the command line.

Comment 7 Elton Woo 2003-05-29 19:26:28 UTC
I did a clean reinstall of the sytem, and print configuration works ok now with 
redhat-config-printer-0.6.47-1, cups-libs-1.1.17-13, cups-1.1.17-13. The sluggishness 
may have been caused by other packages that I had installed from rawhide. (...sorry about 
that!). 
 


Note You need to log in before you can comment on or make changes to this bug.