Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85792 - gnome-terminal up arrow change
Summary: gnome-terminal up arrow change
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: vte
Version: rawhide
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Warren Togami
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-07 20:26 UTC by jmccann
Modified: 2015-01-14 23:19 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-11 10:21:58 UTC


Attachments (Terms of Use)

Description jmccann 2003-03-07 20:26:39 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030211

Description of problem:
It seems that the up arrow key sends a different sequence in gnome-terminal than
it does in an xterm.  This difference seems to break command history editing in
some applications, namely IDL.

Here is a newsgroup thread on the topic:
http://groups.google.com/groups?hl=en&lr=&ie=UTF-8&oe=UTF-8&safe=off&threadm=ap0lqf%246rv%241%40ousrvr3.oulu.fi&rnum=3&prev=/groups%3Fhl%3Den%26lr%3D%26ie%3DUTF-8%26oe%3DUTF-8%26safe%3Doff%26q%3Dgnome%26btnG%3DGoogle%2BSearch%26meta%3Dgroup%253Dcomp.lang.idl-pvwave

I have a support contract with RSI, the people who created IDL, but they don't
have any information about this problem.

I searched bugzilla.gnome.org and didn't find any documentation there either.

I know you don't support IDL at all but I was wondering if you have any
information about why gnome-terminals are different from xterms in this regard.

Thanks.

Version-Release number of selected component (if applicable):

How reproducible:
Always

Steps to Reproduce:
1. open gnome-terminal
2. start IDL
3. type command
4. hit up arrow key

Actual Results:  Previous command is not displayed.

Expected Results:  In a standard Xterm the previous IDL command is displayed.

Comment 1 jmccann 2003-03-21 17:08:52 UTC
It appears that gnome-terminal is getting set to "application mode"
<http://dickey.his.com/xterm/xterm.faq.html#xterm_arrows>.

Comment 2 Warren Togami 2005-09-11 10:21:58 UTC
Closing due to lack of activity.  If this is still an issue you should file it
at the upstream bugzilla.gnome.org.  Fedora has no resources to work on vte.


Note You need to log in before you can comment on or make changes to this bug.