Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85778 - glibc-2.2.93-5 problem on ipv6 name resolution (DNS) on i386/i486/i586
Summary: glibc-2.2.93-5 problem on ipv6 name resolution (DNS) on i386/i486/i586
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc
Version: 8.0
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-07 17:58 UTC by Paulo Matos
Modified: 2016-11-24 15:16 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-08-04 20:38:32 UTC


Attachments (Terms of Use)
'strace ping6 www.kame.net' result (deleted)
2003-03-07 18:01 UTC, Paulo Matos
no flags Details

Description Paulo Matos 2003-03-07 17:58:13 UTC
Description of problem:

It seems that the package glibc-2.2.93-5.i386.rpm shipped with redhat-8.0,
has no ipv6 support.

Looking at strace result on lines 121-131 it simply tries to do a ipv4
query to the default nameserver (resolv.conf has only an ipv6 only server).


Version-Release number of selected component (if applicable):
2.2.93-5 

How reproducible:
Always

Steps to Reproduce:
1.ping6 www.kame.net (e.g)
2.
3.
    
Actual results:


Expected results:


Additional info:

Comment 1 Paulo Matos 2003-03-07 18:01:11 UTC
Created attachment 90517 [details]
'strace ping6 www.kame.net' result

Comment 2 Ulrich Drepper 2003-04-22 08:06:36 UTC
There is no way to compile glibc without IPv6 so this is definitely not the reason.

From your strace output it seems there is a problem with the DNS server. 
Reading the results produces problems.

Anyway, I assume ping6 uses getaddrinfo.  getaddrinfo has been changed
significantly for RHL9.  Please try RHL9 and let us know.

Comment 3 Bill Nottingham 2006-08-04 20:38:32 UTC
Red Hat Linux and Red Hat Powertools are currently no longer supported by Red
Hat, Inc. In an effort to clean up bugzilla, we are closing all bugs in MODIFIED
state for these products.

However, we do want to make sure that nothing important slips through the
cracks. If, in fact, these issues are not resolved in a current Fedora Core
Release (such as Fedora Core 5), please open a new issues stating so. Thanks.


Note You need to log in before you can comment on or make changes to this bug.