Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 8575 - perl/network (on RH6.0 alpha) broken : bad rpm ?
Summary: perl/network (on RH6.0 alpha) broken : bad rpm ?
Keywords:
Status: CLOSED DUPLICATE of bug 2297
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: perl
Version: 6.0
Hardware: alpha
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Crutcher Dunnavant
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-01-18 17:36 UTC by lionel tricon
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-01-18 20:38:52 UTC


Attachments (Terms of Use)

Description lionel tricon 2000-01-18 17:36:01 UTC
The network part of perl seems broken on RH 6.0 (alpha) :

an example :

# perl /usr/lib/perl5/5.00503/alpha-linux/sys/socket.ph
Prototype mismatch: sub main::__need_size_t vs () at (eval 46) line 1.
String found where operator expected at (eval 185) line 1, near "&__const
'struc
t sockaddr'"
        (Missing operator before  'struct sockaddr'?)

but when i recompile perl (perl-5_005_02.tgz and only the binary), the
trouble is resolved and i can use perl in all my network scripts. I saw
that there is no rpm upgrade for this problem.

that's work on SuSE 6.1 alpha :-) so i suppose that it's a bug in the rpm
i have an application wrote in perl which use some network capabilities.

Any thoughts ?

Comment 1 Jeff Johnson 2000-01-18 20:38:59 UTC
*** This bug has been marked as a duplicate of 2297 ***


Note You need to log in before you can comment on or make changes to this bug.