Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85719 - Linking with '-lelf' fails
Summary: Linking with '-lelf' fails
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: libelf
Version: 8.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-06 14:02 UTC by Dave Shield
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-03-09 22:28:42 UTC


Attachments (Terms of Use)

Description Dave Shield 2003-03-06 14:02:10 UTC
Description of problem:
Linking with '-lelf' fails due to the lack of a 'libelf.so' link

Version-Release number of selected component (if applicable):
libelf-0.8.2-2

How reproducible:
Very

Steps to Reproduce:
1. Retrieve and unpack net-snmp tarball
2. ./configure --with-mib-modules=host
3. make
   [There are almost certainly simpler ways to
    reproduce this behaviour!]

Actual results:
gcc   .... -o snmpd ...... -lelf .....
/usr/bin/ld: Cannot find -lelf

Expected results:
Should compile the agent correctly

Additional info:
Fixed by
     ln -s libelf.so.0.8.2 /usr/lib/libelf.so

Comment 1 Jakub Jelinek 2003-03-09 22:28:42 UTC
My guess is that you don't have libelf-devel installed.


Note You need to log in before you can comment on or make changes to this bug.