Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85718 - Run Tests dialog Executables pane checklist drawing problem
Summary: Run Tests dialog Executables pane checklist drawing problem
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: eCos
Classification: Retired
Component: ConfigTool
Version: 2.0 beta 1
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: John Dallaway
QA Contact: John Dallaway
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-06 13:43 UTC by John Dallaway
Modified: 2007-04-18 16:51 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-04-04 13:02:37 UTC


Attachments (Terms of Use)

Description John Dallaway 2003-03-06 13:43:46 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3; Linux)

Description of problem:
The checklist in the Executables pane of the Run Tests dialog does not get drawn properly on Win2k and WinXP hosts. The problem is less marked on Win98SE. Scrolling very slowly will force a redraw and allow you to see the content of the checklist. configtool on Linux is not affected.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Build eCos tests
2. Invoke the Run Tests dialog
3.
    

Actual Results:  Typically only the first executable is seen in the checklist. The others are there but have not been drawn correctly. Scrolling rapidly causes all sorts of mis-drawn content to appear.

Expected Results:  A full list of executables should appear.

Additional info:

The checklist uses wxCheckListBox which requires wxUSE_OWNER_DRAWN support in the wxWindows library. Probably a bug in wxWindows.

eCos Configuration Tool 2.12.net (eCos 2.0b1) built using Visual C++.

Comment 1 John Dallaway 2003-04-03 15:54:54 UTC
Similar issues observed under Win98 have been resolved by building the 
configtool against wxWindows 2.4.0. I need to verify that the issues are also 
resolved on Win2k/WinXP. 

Comment 2 John Dallaway 2003-04-04 13:02:37 UTC
Fixed by building against wxWindows 2.4.0.


Note You need to log in before you can comment on or make changes to this bug.