Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85704 - Improper file test in lang.sh and lang.csh
Summary: Improper file test in lang.sh and lang.csh
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: initscripts
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-06 08:08 UTC by SEKINE Tatsuo
Modified: 2014-03-17 02:34 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-03-06 16:32:55 UTC


Attachments (Terms of Use)

Description SEKINE Tatsuo 2003-03-06 08:08:45 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ja-JP; rv:1.1) Gecko/20021030 for
VineLinux 0vl6

Description of problem:
In lang.sh, /bin/unicode_start program is tested as below:

  [ -f /bin/unicode_start ] && unicode_start ...

But it should be:

  [ -x /bin/unicode_start ] && unicode_start ...

lang.csh is also.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. chmod a-x /bin/unicode_start
2. login
3.
    

Additional info:

This is not a BUG.
It's a only problem of conding style.

Comment 1 Bill Nottingham 2003-03-06 16:32:55 UTC
Fixed in CVS, will be in next build.


Note You need to log in before you can comment on or make changes to this bug.