Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 85667 - multipart/form-data does not work
Summary: multipart/form-data does not work
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: php
Version: 7.3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-03-05 18:55 UTC by Gerald Teschl
Modified: 2007-04-18 16:51 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2003-11-01 15:27:02 UTC


Attachments (Terms of Use)

Description Gerald Teschl 2003-03-05 18:55:16 UTC
Description of problem:
I tried to install squirelmail, but one cannot send emails. I traced the
problem down to the fact that a form using 'multipart/form-data' will
behave like nothing is submitted.

Version-Release number of selected component (if applicable):
php-4.1.2-7.3.6
apache-1.3.27-2

How reproducible:
100%

Steps to Reproduce:
Call the following script
---------------------------------------------
<form action="action.php" method="POST"  ENCTYPE="multipart/form-data">
 Your name: <input type="text" name="name" />
 <input type="submit" name=test>
</form>
<hr>
<?php if (isset($_POST['test'])) { ?>
Hi <?php echo $_POST["name"]; ?>.
<?php } ?>
---------------------------------------------
Enter "xxx" and submit the date.

    
Actual results:
No "Hi xxx." is printed.

Expected results:
"Hi xxx." should be printed.

Additional info:
1) This is not a client problem. I tried different clients.
2) If one removes 'ENCTYPE="multipart/form-data"' it will work.
3) On RH 8.0 the same script works.

Comment 1 Joe Orton 2003-04-07 13:36:24 UTC
You say this *works* in 8.0, yet you have filed this bug against 8.0? Did you
mean to file this against a 7.x release?

Comment 2 Gerald Teschl 2003-04-07 18:10:57 UTC
Sorry, you are right, I wanted to file this against 7.3


Note You need to log in before you can comment on or make changes to this bug.